summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/java-openjfx-build-jdk_version.patch
diff options
context:
space:
mode:
authorAlexey Abramov <levenson@mmer.org>2020-05-30 19:09:43 +0200
committerLudovic Courtès <ludo@gnu.org>2020-06-03 18:05:56 +0200
commitd9ef5aeba757c6f86d2abafe6b62ef4c2516c2e6 (patch)
tree42b7e5f57e465fa7f1d0182fe97eb2f427777c8a /gnu/packages/patches/java-openjfx-build-jdk_version.patch
parentb6c445931e85c07286a79bc9c80fdc956d58b1e2 (diff)
downloadguix-patches-d9ef5aeba757c6f86d2abafe6b62ef4c2516c2e6.tar
guix-patches-d9ef5aeba757c6f86d2abafe6b62ef4c2516c2e6.tar.gz
gnu: java-openjfx-build: Add helpful patch.
* gnu/packages/java.scm (java-openjfx-build)[source]: Use it. * gnu/packages/patches/java-openjfx-build-jdk_version.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Alexey Abramov <levenson@mmer.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/java-openjfx-build-jdk_version.patch')
-rw-r--r--gnu/packages/patches/java-openjfx-build-jdk_version.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/java-openjfx-build-jdk_version.patch b/gnu/packages/patches/java-openjfx-build-jdk_version.patch
new file mode 100644
index 0000000000..7be954467a
--- /dev/null
+++ b/gnu/packages/patches/java-openjfx-build-jdk_version.patch
@@ -0,0 +1,27 @@
+Subject: [PATCH] openjfx: Determine the version of Java in JDK_HOME
+
+Icedtea contains guix in its version, so build.gradle failes to run. Openjfx
+packaging is not trivial, so you will probably need to try build it with
+gradlew.
+
+---
+ build.gradle | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/build.gradle b/build.gradle
+index df82f63..2c626cd 100644
+--- a/build.gradle
++++ b/build.gradle
+@@ -742,9 +742,9 @@ try {
+ if (inStream.readLine() != null) {
+ String v = inStream.readLine();
+ if (v != null) {
+- int ib = v.indexOf(" (build ");
++ int ib = v.indexOf(" (guix build ");
+ if (ib != -1) {
+- String ver = v.substring(ib + 8, v.size() - 1);
++ String ver = v.substring(ib + 13, v.size() - 1);
+
+ defineProperty("jdkRuntimeVersion", ver)
+ defineProperty("jdkVersion", jdkRuntimeVersion.split("-")[0])
+2.24.1