summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ilmbase-openexr-pkg-config.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-09-23 17:15:50 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-09-24 20:12:56 +0200
commit942c7889498fc8e680a16d500e166c9ade84e640 (patch)
treeba82db572d0c84fa79a34d79c26545352852a15d /gnu/packages/patches/ilmbase-openexr-pkg-config.patch
parentd8fbfbf52363333b5f925a52edc4e5bbc85c45de (diff)
downloadguix-patches-942c7889498fc8e680a16d500e166c9ade84e640.tar
guix-patches-942c7889498fc8e680a16d500e166c9ade84e640.tar.gz
gnu: OpenEXR: Update to 2.4.0 [fixes CVE-2018-18443, CVE-2018-18444].
* gnu/packages/patches/ilmbase-fix-tests.patch: Adjust for new origin. * gnu/packages/patches/ilmbase-openexr-pkg-config.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/graphics.scm (ilmbase): Update to 2.4.0. [source]: Change to GIT-FETCH, as tarballs are no longer provided. Add new patch. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/graphics.scm (openexr): Update to 2.4.0. [source]: Inherit from ILMBASE, which comes from the same repository. [build-system]: Change to CMAKE-BUILD-SYSTEM. [arguments]: Add phase to enter the correct source directory. * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Enable C++11. * gnu/packages/image-processing.scm (opencv)[arguments]: Likewise.
Diffstat (limited to 'gnu/packages/patches/ilmbase-openexr-pkg-config.patch')
-rw-r--r--gnu/packages/patches/ilmbase-openexr-pkg-config.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/ilmbase-openexr-pkg-config.patch b/gnu/packages/patches/ilmbase-openexr-pkg-config.patch
new file mode 100644
index 0000000000..99613080d8
--- /dev/null
+++ b/gnu/packages/patches/ilmbase-openexr-pkg-config.patch
@@ -0,0 +1,40 @@
+Fix pkg-config files when using the CMake build system.
+
+Upstream bug report:
+https://github.com/openexr/openexr/issues/567
+
+diff --git a/IlmBase/config/CMakeLists.txt b/IlmBase/config/CMakeLists.txt
+index 508176a..9e6ab91 100644
+--- a/IlmBase/config/CMakeLists.txt
++++ b/IlmBase/config/CMakeLists.txt
+@@ -71,9 +71,9 @@ if(ILMBASE_INSTALL_PKG_CONFIG)
+ # use a helper function to avoid variable pollution, but pretty simple
+ function(ilmbase_pkg_config_help pcinfile)
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
+- set(libdir ${CMAKE_INSTALL_LIBDIR})
+- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
++ set(exec_prefix ${CMAKE_INSTALL_FULL_BINDIR})
++ set(libdir ${CMAKE_INSTALL_FULL_LIBDIR})
++ set(includedir ${CMAKE_INSTALL_FULL_INCLUDEDIR})
+ set(LIB_SUFFIX_DASH ${ILMBASE_LIB_SUFFIX})
+ if(TARGET Threads::Threads)
+ # hrm, can't use properties as they end up as generator expressions
+diff --git a/OpenEXR/config/CMakeLists.txt b/OpenEXR/config/CMakeLists.txt
+index 1ef829a..b8dc141 100644
+--- a/OpenEXR/config/CMakeLists.txt
++++ b/OpenEXR/config/CMakeLists.txt
+@@ -72,9 +72,9 @@ if(OPENEXR_INSTALL_PKG_CONFIG)
+ # use a helper function to avoid variable pollution, but pretty simple
+ function(openexr_pkg_config_help pcinfile)
+ set(prefix ${CMAKE_INSTALL_PREFIX})
+- set(exec_prefix ${CMAKE_INSTALL_BINDIR})
+- set(libdir ${CMAKE_INSTALL_LIBDIR})
+- set(includedir ${CMAKE_INSTALL_INCLUDEDIR})
++ set(exec_prefix ${CMAKE_INSTALL_FULL_BINDIR})
++ set(libdir ${CMAKE_INSTALL_FULL_LIBDIR})
++ set(includedir ${CMAKE_INSTALL_FULL_INCLUDEDIR})
+ set(LIB_SUFFIX_DASH ${OPENEXR_LIB_SUFFIX})
+ if(TARGET Threads::Threads)
+ # hrm, can't use properties as they end up as generator expressions
+