summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/icecat-avoid-bundled-libraries.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-09-24 00:10:37 -0400
committerMark H Weaver <mhw@netris.org>2018-09-25 19:59:06 -0400
commit94e96f7f68c3b9053fdb5dee5b0ab614163aaa08 (patch)
tree54ac4e1b456228def69c5e87a56d869394bc75f3 /gnu/packages/patches/icecat-avoid-bundled-libraries.patch
parent257e3247910610fe24ae1b86f38e85552d53e48c (diff)
downloadguix-patches-94e96f7f68c3b9053fdb5dee5b0ab614163aaa08.tar
guix-patches-94e96f7f68c3b9053fdb5dee5b0ab614163aaa08.tar.gz
gnu: icecat: Unbundle libevent, libogg, and libvorbis.
* gnu/packages/patches/icecat-use-system-media-libs.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/patches/icecat-avoid-bundled-libraries.patch: Add another hunk to enable removal of libevent. * gnu/packages/gnuzilla.scm (icecat)[source]: Add patch. In the snippet, add libevent, libogg, libvorbis, and libtremor to the list of bundled libraries to remove. Add a comment regarding theora. Remove comments regarding unbundling cairo, which is no longer supported. [inputs]: Add libevent, libogg, and libvorbis. [arguments]: Add --with-system-{libevent,ogg,vorbis} to configure flags. Add custom bootstrap phase. Add comments.
Diffstat (limited to 'gnu/packages/patches/icecat-avoid-bundled-libraries.patch')
-rw-r--r--gnu/packages/patches/icecat-avoid-bundled-libraries.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-avoid-bundled-libraries.patch b/gnu/packages/patches/icecat-avoid-bundled-libraries.patch
index b5e9fb887e..33203b1a33 100644
--- a/gnu/packages/patches/icecat-avoid-bundled-libraries.patch
+++ b/gnu/packages/patches/icecat-avoid-bundled-libraries.patch
@@ -33,3 +33,17 @@ Fixes needed when avoiding bundled libraries.
'/dom/base',
'/dom/storage',
'/ipc/glue',
+--- icecat-60.2.0/media/webrtc/trunk/webrtc/base/rtc_task_queue_gn/moz.build.orig 2018-09-13 17:40:54.000000000 -0400
++++ icecat-60.2.0/media/webrtc/trunk/webrtc/base/rtc_task_queue_gn/moz.build 2018-09-23 21:33:12.319975105 -0400
+@@ -130,11 +130,6 @@
+ DEFINES["WEBRTC_POSIX"] = True
+ DEFINES["_FILE_OFFSET_BITS"] = "64"
+
+- LOCAL_INCLUDES += [
+- "/ipc/chromium/src/third_party/libevent/include/",
+- "/ipc/chromium/src/third_party/libevent/linux/"
+- ]
+-
+ UNIFIED_SOURCES += [
+ "/media/webrtc/trunk/webrtc/base/task_queue_libevent.cc",
+ "/media/webrtc/trunk/webrtc/base/task_queue_posix.cc"