summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/hueplusplus-mbedtls.patch
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-01-02 11:38:03 -0500
committerLeo Famulari <leo@famulari.name>2022-01-06 13:18:19 -0500
commitfb8568857fbbfc46c01c47099da364639ca69d88 (patch)
treea7be760cbe34495ffd079eeb836f65498b9b4991 /gnu/packages/patches/hueplusplus-mbedtls.patch
parent2860bb2779dbc557ab5362b531d9f497f34b41d8 (diff)
downloadguix-patches-fb8568857fbbfc46c01c47099da364639ca69d88.tar
guix-patches-fb8568857fbbfc46c01c47099da364639ca69d88.tar.gz
gnu: Add hueplusplus.
* gnu/packages/hardware.scm (hueplusplus): New variable. * gnu/packages/patches/hueplusplus-mbedtls.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/hueplusplus-mbedtls.patch')
-rw-r--r--gnu/packages/patches/hueplusplus-mbedtls.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/hueplusplus-mbedtls.patch b/gnu/packages/patches/hueplusplus-mbedtls.patch
new file mode 100644
index 0000000000..894590af8d
--- /dev/null
+++ b/gnu/packages/patches/hueplusplus-mbedtls.patch
@@ -0,0 +1,20 @@
+Remove references to bundled mbedtls library to use the one from inputs.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 1e27d21..f0eb1a5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -85,13 +85,6 @@ endif()
+
+ set(USE_STATIC_MBEDTLS_LIBRARY ON)
+ set(USE_SHARED_MBEDTLS_LIBRARY OFF)
+-add_subdirectory("lib/mbedtls" EXCLUDE_FROM_ALL)
+-
+-# Compile the mbedtls library as a static with position independent code,
+-# because we need it for both a shared and static library
+-set_property(TARGET mbedtls PROPERTY POSITION_INDEPENDENT_CODE ON)
+-set_property(TARGET mbedcrypto PROPERTY POSITION_INDEPENDENT_CODE ON)
+-set_property(TARGET mbedx509 PROPERTY POSITION_INDEPENDENT_CODE ON)
+
+ add_subdirectory(src)
+