summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/hubbub-sort-entities.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:23:52 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:25 -0600
commit43bfbf137043c2e86ae907528ab830d66e86c642 (patch)
tree8a3286275d5e53dd89a4e3b65bdfc02e666ccc7c /gnu/packages/patches/hubbub-sort-entities.patch
parentef61177dddcedaf773e83aa99feef113537e5d92 (diff)
downloadguix-patches-43bfbf137043c2e86ae907528ab830d66e86c642.tar
guix-patches-43bfbf137043c2e86ae907528ab830d66e86c642.tar.gz
gnu: Add hubbub.
* gnu/packages/web.scm (hubbub): New variable.
Diffstat (limited to 'gnu/packages/patches/hubbub-sort-entities.patch')
-rw-r--r--gnu/packages/patches/hubbub-sort-entities.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/hubbub-sort-entities.patch b/gnu/packages/patches/hubbub-sort-entities.patch
new file mode 100644
index 0000000000..012e3c3022
--- /dev/null
+++ b/gnu/packages/patches/hubbub-sort-entities.patch
@@ -0,0 +1,13 @@
+Traverse the entities hash's keys in sorted order to ensure reproducibility.
+
+--- libhubbub-0.3.3/build/make-entities.pl
++++ libhubbub-0.3.3/build/make-entities.pl
+@@ -86,7 +86,7 @@
+
+ my $trie;
+
+-foreach my $key (keys %entities) {
++foreach my $key (sort keys %entities) {
+ $trie = insert_node($trie, $key, $entities{$key});
+ }
+