summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gzdoom-search-in-installed-share.patch
diff options
context:
space:
mode:
authorokapi <okapi@firemail.cc>2018-01-17 00:21:42 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-19 00:33:34 +0100
commit2922852e86b5173d45d1097b8cb72f8e081b4152 (patch)
treed3ee60c1dfd271ceafdca7c69a7da1dca3f872cd /gnu/packages/patches/gzdoom-search-in-installed-share.patch
parent9073c8758ceb0d39e3c7c2985e5a1fc06ba4076a (diff)
downloadguix-patches-2922852e86b5173d45d1097b8cb72f8e081b4152.tar
guix-patches-2922852e86b5173d45d1097b8cb72f8e081b4152.tar.gz
gnu: Add gzdoom.
* gnu/packages/games.scm (gzdoom): New variable. * gnu/packages/patches/gzdoom-search-in-installed-share.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/gzdoom-search-in-installed-share.patch')
-rw-r--r--gnu/packages/patches/gzdoom-search-in-installed-share.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/gzdoom-search-in-installed-share.patch b/gnu/packages/patches/gzdoom-search-in-installed-share.patch
new file mode 100644
index 0000000000..f312686566
--- /dev/null
+++ b/gnu/packages/patches/gzdoom-search-in-installed-share.patch
@@ -0,0 +1,23 @@
+Lookup gzdoom pk3 files in the installed directory in
+addition to the path that is stored in ~/.config/gzdoom/.
+
+Simply replacing the hardcoded /usr/share would leave the
+configfile pointing to outdated guix builds, which could get
+garbage collected and break the gzdoom installation.
+This ensures that the files installed with the corresponding
+build will be used.
+
+--- /src/d_main.cpp 2018-01-16 22:13:09.700602781 +0200
++++ /src/d_main.cpp 2018-01-16 22:22:36.560617961 +0200
+@@ -1716,6 +1716,11 @@
+ return wad;
+ }
+
++ mysnprintf (wad, countof(wad), "%s/%s", GUIX_OUT_PK3, file);
++ if (DirEntryExists (wad)) {
++ return wad;
++ }
++
+ if (GameConfig != NULL && GameConfig->SetSection ("FileSearch.Directories"))
+ {
+ const char *key;