summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/guile-linux-syscalls.patch
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-06-18 20:21:41 -0400
committerDavid Thompson <davet@gnu.org>2015-06-19 07:49:18 -0400
commit5fd77f3f437e9a648adc18efa8eb753b17915c9e (patch)
treef867149080221b21d9beb8740263a9bd8ac52fb0 /gnu/packages/patches/guile-linux-syscalls.patch
parent14a983c28ad0a06aeb90c9fc8ce8108fcf4f4eac (diff)
downloadguix-patches-5fd77f3f437e9a648adc18efa8eb753b17915c9e.tar
guix-patches-5fd77f3f437e9a648adc18efa8eb753b17915c9e.tar.gz
gnu: Make 'mount' interface in static Guile consistent with Guix API.
Rather than expecting a pointer, the version of 'mount' in guile-static-stripped now takes a string for the 'options' argument, just like the 'mount' procedure in (guix build syscalls). * gnu/packages/patches/guile-linux-syscalls.patch (mount): Expect a string or #f for 'options' argument. * gnu/build/file-systems.scm (mount-file-system): Use new 'mount' interface.
Diffstat (limited to 'gnu/packages/patches/guile-linux-syscalls.patch')
-rw-r--r--gnu/packages/patches/guile-linux-syscalls.patch16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/patches/guile-linux-syscalls.patch b/gnu/packages/patches/guile-linux-syscalls.patch
index 57c7f2589d..73a062bda1 100644
--- a/gnu/packages/patches/guile-linux-syscalls.patch
+++ b/gnu/packages/patches/guile-linux-syscalls.patch
@@ -7,10 +7,10 @@ diff --git a/libguile/posix.c b/libguile/posix.c
index 324f21b..cbee94d 100644
--- a/libguile/posix.c
+++ b/libguile/posix.c
-@@ -2286,6 +2286,261 @@ scm_init_popen (void)
+@@ -2245,6 +2245,267 @@ scm_init_popen (void)
}
#endif
-
+
+
+/* Linux! */
+
@@ -25,15 +25,18 @@ index 324f21b..cbee94d 100644
+#define FUNC_NAME s_scm_mount
+{
+ int err;
-+ char *c_source, *c_target, *c_type;
++ char *c_source, *c_target, *c_type, *c_data;
+ unsigned long c_flags;
-+ void *c_data;
+
+ c_source = scm_to_locale_string (source);
+ c_target = scm_to_locale_string (target);
+ c_type = scm_to_locale_string (type);
+ c_flags = SCM_UNBNDP (flags) ? 0 : scm_to_ulong (flags);
-+ c_data = SCM_UNBNDP (data) ? NULL : scm_to_pointer (data);
++
++ if (SCM_UNBNDP (data) || scm_is_false (data))
++ c_data = NULL;
++ else
++ c_data = scm_to_locale_string (data);
+
+ err = mount (c_source, c_target, c_type, c_flags, c_data);
+ if (err != 0)
@@ -43,6 +46,9 @@ index 324f21b..cbee94d 100644
+ free (c_target);
+ free (c_type);
+
++ if (c_data != NULL)
++ free (c_data);
++
+ if (err != 0)
+ {
+ errno = err;