summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-04-24 13:56:56 -0400
committerLeo Famulari <leo@famulari.name>2021-04-27 01:58:55 -0400
commitc48b8fed25c6f9bca95bbae9f85e333be70a6ee0 (patch)
tree43572c8a3d1dc643c995e432d4ac2b730fb4c0ce /gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch
parent0cb4ef1c7f8b2f14f1dfa588949fb16b918731c5 (diff)
downloadguix-patches-c48b8fed25c6f9bca95bbae9f85e333be70a6ee0.tar
guix-patches-c48b8fed25c6f9bca95bbae9f85e333be70a6ee0.tar.gz
gnu: gst-plugins-good: Fix CVE-2021-3497 and CVE-2021-3498.
* gnu/packages/patches/gst-plugins-good-CVE-2021-3497.patch, gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. * gnu/packages/gstreamer.scm (gst-plugins-good)[source]: Use them.
Diffstat (limited to 'gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch')
-rw-r--r--gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch b/gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch
new file mode 100644
index 0000000000..50eb42f126
--- /dev/null
+++ b/gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch
@@ -0,0 +1,22 @@
+Fix CVE-2021-3498:
+
+https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3498
+https://gstreamer.freedesktop.org/security/sa-2021-0003.html
+
+Patch copied from upstream source repository:
+
+https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/commit/02174790726dd20a5c73ce2002189bf240ad4fe0?merge_request_iid=903
+
+diff --git a/gst/matroska/matroska-demux.c b/gst/matroska/matroska-demux.c
+index 4d0234743b8cf243b4521e56ef9027ba23b1b5d0..467815986c8c3d86fd8906a0d539b34f67d6693e 100644
+--- a/gst/matroska/matroska-demux.c
++++ b/gst/matroska/matroska-demux.c
+@@ -692,6 +692,8 @@ gst_matroska_demux_parse_stream (GstMatroskaDemux * demux, GstEbmlRead * ebml,
+
+ DEBUG_ELEMENT_START (demux, ebml, "TrackEntry");
+
++ *dest_context = NULL;
++
+ /* start with the master */
+ if ((ret = gst_ebml_read_master (ebml, &id)) != GST_FLOW_OK) {
+ DEBUG_ELEMENT_STOP (demux, ebml, "TrackEntry", ret);