summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/grub-setup-root.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-11 02:05:33 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-12 20:58:16 +0200
commit2d115ea7edd4d5d85df18424e1e691935184a8c8 (patch)
treedf3102170150834137112db92be7564761c8a2a2 /gnu/packages/patches/grub-setup-root.patch
parent154a4e046281c28e39b5016e965d3d937a2ea4a1 (diff)
downloadguix-patches-2d115ea7edd4d5d85df18424e1e691935184a8c8.tar
guix-patches-2d115ea7edd4d5d85df18424e1e691935184a8c8.tar.gz
gnu: grub: Update to 2.06.
[source]: Remove upstreamed patches. * gnu/packages/patches/grub-setup-root.patch: Update patch. * gnu/packages/patches/grub-verifiers-Blocklist-fallout-cleanup.patch, gnu/packages/patches/grub-cross-system-i686.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/grub-setup-root.patch')
-rw-r--r--gnu/packages/patches/grub-setup-root.patch99
1 files changed, 54 insertions, 45 deletions
diff --git a/gnu/packages/patches/grub-setup-root.patch b/gnu/packages/patches/grub-setup-root.patch
index 1abe9c383a..e64a7dd6be 100644
--- a/gnu/packages/patches/grub-setup-root.patch
+++ b/gnu/packages/patches/grub-setup-root.patch
@@ -1,9 +1,53 @@
This patch is taken from OpenWrt, see:
-https://github.com/openwrt/openwrt/blob/master/package/boot/grub2/patches/100-grub_setup_root.patch.
+https://github.com/openwrt/openwrt/blob/master/package/boot/grub2/patches/100-grub_setup_root.patch
+
+nckx changed `char *root' to lazily pacify -Werror=discarded-qualifiers.
It allows to use grub-bios-setup on a raw disk-images, without root permissions.
+--- a/include/grub/util/install.h
++++ b/include/grub/util/install.h
+@@ -198,13 +198,13 @@ grub_install_get_image_target (const char *arg);
+ void
+ grub_util_bios_setup (const char *dir,
+ const char *boot_file, const char *core_file,
+- const char *dest, int force,
++ char *root, const char *dest, int force,
+ int fs_probe, int allow_floppy,
+ int add_rs_codes, int warn_short_mbr_gap);
+ void
+ grub_util_sparc_setup (const char *dir,
+ const char *boot_file, const char *core_file,
+- const char *dest, int force,
++ char *root, const char *dest, int force,
+ int fs_probe, int allow_floppy,
+ int add_rs_codes, int warn_short_mbr_gap);
+
+diff --git a/util/grub-install.c b/util/grub-install.c
+index 0fbe7f78c..7f06aa1e3 100644
+--- a/util/grub-install.c
++++ b/util/grub-install.c
+@@ -1721,7 +1721,7 @@ main (int argc, char *argv[])
+ if (install_bootsector)
+ {
+ grub_util_bios_setup (platdir, "boot.img", "core.img",
+- install_drive, force,
++ NULL, install_drive, force,
+ fs_probe, allow_floppy, add_rs_codes,
+ !grub_install_is_short_mbrgap_supported ());
+
+@@ -1752,7 +1752,7 @@ main (int argc, char *argv[])
+ if (install_bootsector)
+ {
+ grub_util_sparc_setup (platdir, "boot.img", "core.img",
+- install_drive, force,
++ NULL, install_drive, force,
+ fs_probe, allow_floppy,
+ 0 /* unused */, 0 /* unused */ );
+
+diff --git a/util/grub-setup.c b/util/grub-setup.c
+index 1783224dd..48cde4950 100644
--- a/util/grub-setup.c
+++ b/util/grub-setup.c
@@ -87,6 +87,8 @@ static struct argp_option options[] = {
@@ -23,7 +67,7 @@ It allows to use grub-bios-setup on a raw disk-images, without root permissions.
int force;
int fs_probe;
int allow_floppy;
-@@ -178,6 +181,13 @@ argp_parser (int key, char *arg, struct
+@@ -178,6 +181,13 @@ argp_parser (int key, char *arg, struct argp_state *state)
arguments->dev_map = xstrdup (arg);
break;
@@ -44,18 +88,21 @@ It allows to use grub-bios-setup on a raw disk-images, without root permissions.
- dest_dev, arguments.force,
+ arguments.root_dev, dest_dev, arguments.force,
arguments.fs_probe, arguments.allow_floppy,
- arguments.add_rs_codes);
+ arguments.add_rs_codes, 0);
+diff --git a/util/setup.c b/util/setup.c
+index da5f2c07f..193745a9c 100644
--- a/util/setup.c
+++ b/util/setup.c
-@@ -252,13 +252,12 @@ identify_partmap (grub_disk_t disk __att
+@@ -252,14 +252,13 @@ identify_partmap (grub_disk_t disk __attribute__ ((unused)),
void
SETUP (const char *dir,
const char *boot_file, const char *core_file,
- const char *dest, int force,
+ char *root, const char *dest, int force,
int fs_probe, int allow_floppy,
- int add_rs_codes __attribute__ ((unused))) /* unused on sparc64 */
+ int add_rs_codes __attribute__ ((unused)), /* unused on sparc64 */
+ int warn_small)
{
char *core_path;
char *boot_img, *core_img, *boot_path;
@@ -63,7 +110,7 @@ It allows to use grub-bios-setup on a raw disk-images, without root permissions.
size_t boot_size, core_size;
grub_uint16_t core_sectors;
grub_device_t root_dev = 0, dest_dev, core_dev;
-@@ -307,7 +306,10 @@ SETUP (const char *dir,
+@@ -311,7 +310,10 @@ SETUP (const char *dir,
core_dev = dest_dev;
@@ -75,7 +122,7 @@ It allows to use grub-bios-setup on a raw disk-images, without root permissions.
char **root_devices = grub_guess_root_devices (dir);
char **cur;
int found = 0;
-@@ -320,6 +322,8 @@ SETUP (const char *dir,
+@@ -324,6 +326,8 @@ SETUP (const char *dir,
char *drive;
grub_device_t try_dev;
@@ -84,41 +131,3 @@ It allows to use grub-bios-setup on a raw disk-images, without root permissions.
drive = grub_util_get_grub_dev (*cur);
if (!drive)
continue;
---- a/include/grub/util/install.h
-+++ b/include/grub/util/install.h
-@@ -191,13 +191,13 @@ grub_install_get_image_target (const cha
- void
- grub_util_bios_setup (const char *dir,
- const char *boot_file, const char *core_file,
-- const char *dest, int force,
-+ char *root, const char *dest, int force,
- int fs_probe, int allow_floppy,
- int add_rs_codes);
- void
- grub_util_sparc_setup (const char *dir,
- const char *boot_file, const char *core_file,
-- const char *dest, int force,
-+ char *root, const char *dest, int force,
- int fs_probe, int allow_floppy,
- int add_rs_codes);
-
---- a/util/grub-install.c
-+++ b/util/grub-install.c
-@@ -1712,7 +1712,7 @@ main (int argc, char *argv[])
- /* Now perform the installation. */
- if (install_bootsector)
- grub_util_bios_setup (platdir, "boot.img", "core.img",
-- install_drive, force,
-+ NULL, install_drive, force,
- fs_probe, allow_floppy, add_rs_codes);
- break;
- }
-@@ -1738,7 +1738,7 @@ main (int argc, char *argv[])
- /* Now perform the installation. */
- if (install_bootsector)
- grub_util_sparc_setup (platdir, "boot.img", "core.img",
-- install_drive, force,
-+ NULL, install_drive, force,
- fs_probe, allow_floppy,
- 0 /* unused */ );
- break;