summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/grub-cross-system-i686.patch
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2020-06-21 15:18:18 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-06-25 17:46:37 +0200
commitd613991a8ebe5d4b3a7706f8f0dd52f16fc1c50a (patch)
tree0c5fcdf672b5cbc03bf3d0e7bb21ce182ebf11a1 /gnu/packages/patches/grub-cross-system-i686.patch
parentdda267e3a7550620a4995b01f36013a8f30ca6bc (diff)
downloadguix-patches-d613991a8ebe5d4b3a7706f8f0dd52f16fc1c50a.tar
guix-patches-d613991a8ebe5d4b3a7706f8f0dd52f16fc1c50a.tar.gz
gnu: grub: Cross-build fix for system i686-linux.
* gnu/packages/patches/grub-cross-system-i686.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/bootloaders.scm (grub): Use it.
Diffstat (limited to 'gnu/packages/patches/grub-cross-system-i686.patch')
-rw-r--r--gnu/packages/patches/grub-cross-system-i686.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/gnu/packages/patches/grub-cross-system-i686.patch b/gnu/packages/patches/grub-cross-system-i686.patch
new file mode 100644
index 0000000000..a376cae1db
--- /dev/null
+++ b/gnu/packages/patches/grub-cross-system-i686.patch
@@ -0,0 +1,79 @@
+Not upstreamed.
+Fixes cross-build for the Hurd, from i686-linux,
+see <https://bugs.gnu.org/41982>.
+
+From 270667540146f8ef9ea7a44258a71b3837a7af4a Mon Sep 17 00:00:00 2001
+From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
+Date: Sun, 21 Jun 2020 15:10:40 +0200
+Subject: [PATCH] grub-core: Build fixes for i386
+
+* grub-core/lib/i386/relocator64.S: Avoid x86_64 instructions on i386.
+---
+ grub-core/lib/i386/relocator64.S | 26 +++++++++++++++++++++++++-
+ 1 file changed, 25 insertions(+), 1 deletion(-)
+
+diff --git a/grub-core/lib/i386/relocator64.S b/grub-core/lib/i386/relocator64.S
+index 148f38adb..45fed9444 100644
+--- a/grub-core/lib/i386/relocator64.S
++++ b/grub-core/lib/i386/relocator64.S
+@@ -63,7 +63,9 @@ VARIABLE(grub_relocator64_cr3)
+ movq %rax, %cr3
+ #endif
+
++#ifdef __x86_64__
+ .code64
++#endif
+
+ /* mov imm64, %rax */
+ .byte 0x48
+@@ -71,7 +73,14 @@ VARIABLE(grub_relocator64_cr3)
+ VARIABLE(grub_relocator64_rsp)
+ .quad 0
+
++#ifndef __x86_64__
++ /* movq %rax, %rsp */
++ .byte 0x48
++ .byte 0x89
++ .byte 0xc4
++#else
+ movq %rax, %rsp
++#endif
+
+ #ifdef GRUB_MACHINE_EFI
+ jmp LOCAL(skip_efi_stack_align)
+@@ -95,8 +104,15 @@ LOCAL(skip_efi_stack_align):
+ VARIABLE(grub_relocator64_rsi)
+ .quad 0
+
++#ifndef __x86_64__
++ /* movq %rax, %rsi */
++ .byte 0x48
++ .byte 0x89
++ .byte 0xc6
++#else
+ movq %rax, %rsi
+-
++#endif
++
+ /* mov imm64, %rax */
+ .byte 0x48
+ .byte 0xb8
+@@ -128,6 +144,14 @@ VARIABLE(grub_relocator64_rdx)
+ #ifdef __APPLE__
+ .byte 0xff, 0x25
+ .quad 0
++#elif !defined (__x86_64__)
++ /* jmp *LOCAL(jump_addr) (%rip) */
++ .byte 0xff
++ .byte 0x25
++ .byte 0
++ .byte 0
++ .byte 0
++ .byte 0
+ #else
+ jmp *LOCAL(jump_addr) (%rip)
+ #endif
+--
+Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
+Freelance IT http://JoyofSource.com | AvatarĀ® http://AvatarAcademy.com
+