summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gpaste-fix-paths.patch
diff options
context:
space:
mode:
authorAttila Lendvai <attila@lendvai.name>2022-01-07 13:50:30 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 11:16:51 +0100
commita485e1e663060e8c62103d81dfffec591f624360 (patch)
treeef04581143f797ff33db37b283e0dd6265daddda /gnu/packages/patches/gpaste-fix-paths.patch
parent4b8a5205a6c2d1894be955bf934b29767e9ffd1e (diff)
downloadguix-patches-a485e1e663060e8c62103d81dfffec591f624360.tar
guix-patches-a485e1e663060e8c62103d81dfffec591f624360.tar.gz
gnu: Add gpaste.
* gnu/packages/gnome-xyz.scm (gpaste): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/patches/gpaste-fix-paths.patch')
-rw-r--r--gnu/packages/patches/gpaste-fix-paths.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/gpaste-fix-paths.patch b/gnu/packages/patches/gpaste-fix-paths.patch
new file mode 100644
index 0000000000..be63878fe6
--- /dev/null
+++ b/gnu/packages/patches/gpaste-fix-paths.patch
@@ -0,0 +1,24 @@
+This is copied from NixOS, which is under MIT licence.
+https://github.com/NixOS/nixpkgs/blob/master/pkgs/desktops/gnome/misc/gpaste/
+--- a/src/gnome-shell/extension.js
++++ b/src/gnome-shell/extension.js
+@@ -6,6 +6,8 @@
+
+ const Config = imports.misc.config;
+
++imports.gi.GIRepository.Repository.prepend_search_path('@typelibPath@');
++
+ imports.gi.versions.Clutter = Config.LIBMUTTER_API_VERSION;
+ imports.gi.versions.GLib = '2.0';
+ imports.gi.versions.GPaste = '1.0';
+--- a/src/gnome-shell/prefs.js
++++ b/src/gnome-shell/prefs.js
+@@ -6,6 +6,8 @@
+
+ const Gettext = imports.gettext;
+
++imports.gi.GIRepository.Repository.prepend_search_path('@typelibPath@');
++
+ //const { GPaste } = imports.gi;
+
+ const ExtensionUtils = imports.misc.extensionUtils;