summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gobject-introspection-cc.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-20 17:57:52 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-22 09:57:51 +0800
commitcc84b08c7821be4a2e2143f139957639bd59fc58 (patch)
treeb9f8a96573869ee1e574d1ed5cfdaff16c81e5ca /gnu/packages/patches/gobject-introspection-cc.patch
parentb837e658bdab9e68d17fc0b326ff4556ab623a6b (diff)
downloadguix-patches-cc84b08c7821be4a2e2143f139957639bd59fc58.tar
guix-patches-cc84b08c7821be4a2e2143f139957639bd59fc58.tar.gz
gnu: gobject-introspection: Update to 1.44.0.
* gnu/packages/glib.scm (gobject-introspection): Update to 1.44.0. [source]: Use mirror://gnome. [arguments]<#:phases>: Remove. * gnu/packages/patches/gobject-introspection-cc.patch: Rewrite to set os.environ['CC'] in 'giscanner/__init__.py'.
Diffstat (limited to 'gnu/packages/patches/gobject-introspection-cc.patch')
-rw-r--r--gnu/packages/patches/gobject-introspection-cc.patch25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/patches/gobject-introspection-cc.patch b/gnu/packages/patches/gobject-introspection-cc.patch
index 38b919a746..d9cacf4ca7 100644
--- a/gnu/packages/patches/gobject-introspection-cc.patch
+++ b/gnu/packages/patches/gobject-introspection-cc.patch
@@ -1,14 +1,11 @@
---- a/giscanner/sourcescanner.py 2013-12-15 23:03:54.002937000 +0100
-+++ b/giscanner/sourcescanner.py 2013-12-15 23:04:50.322937000 +0100
-@@ -277,6 +277,11 @@
- defines = ['__GI_SCANNER__']
- undefs = []
- cpp_args = os.environ.get('CC', 'cc').split() # support CC="ccache gcc"
-+ if (cpp_args == ['cc'] and
-+ not any(map(lambda x: os.access(os.path.join(x, 'cc'), os.X_OK),
-+ os.environ.get('PATH').split(':')))):
-+ cpp_args = ['GUIX_GCC_PATH']
-+
- if 'cl' in cpp_args:
- # The Microsoft compiler/preprocessor (cl) does not accept
- # source input from stdin (the '-' flag), so we need
+Use gcc as the default C compiler if CC is not set.
+
+
+--- gobject-introspection-1.44.0.orig/giscanner/__init__.py 2014-08-04 22:37:07.000000000 +0800
++++ gobject-introspection-1.44.0/giscanner/__init__.py 2015-04-20 17:30:26.507697234 +0800
+@@ -22,3 +22,5 @@
+ builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
+ if builddir is not None:
+ __path__.append(os.path.join(builddir, 'giscanner'))
++if not 'CC' in os.environ:
++ os.environ['CC'] = 'gcc'