summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnupg-CVE-2022-34903.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-09 22:39:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-09 22:39:26 +0300
commit9a53a79fc54e01932bd727ec519403ea4c2c3efc (patch)
tree61972203eec04b04d86a89414a633ca07b154b5d /gnu/packages/patches/gnupg-CVE-2022-34903.patch
parent987f5acb2d13bf475b0c5bc6cf0ceea787fb1c20 (diff)
downloadguix-patches-9a53a79fc54e01932bd727ec519403ea4c2c3efc.tar
guix-patches-9a53a79fc54e01932bd727ec519403ea4c2c3efc.tar.gz
gnu: gnupg: Patch CVE-2022-34903.
* gnu/packages/gnupg.scm (gnupg)[replacement]: New field. (gnupg/replacement): New variable. * gnu/packages/patches/gnupg-CVE-2022-34903.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/gnupg-CVE-2022-34903.patch')
-rw-r--r--gnu/packages/patches/gnupg-CVE-2022-34903.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnupg-CVE-2022-34903.patch b/gnu/packages/patches/gnupg-CVE-2022-34903.patch
new file mode 100644
index 0000000000..19c055282a
--- /dev/null
+++ b/gnu/packages/patches/gnupg-CVE-2022-34903.patch
@@ -0,0 +1,54 @@
+https://dev.gnupg.org/T6027
+https://www.openwall.com/lists/oss-security/2022/06/30/1
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commit;h=34c649b3601383cd11dbc76221747ec16fd68e1b
+
+From 34c649b3601383cd11dbc76221747ec16fd68e1b Mon Sep 17 00:00:00 2001
+From: Werner Koch <wk@gnupg.org>
+Date: Tue, 14 Jun 2022 11:33:27 +0200
+Subject: [PATCH] g10: Fix garbled status messages in NOTATION_DATA
+
+* g10/cpr.c (write_status_text_and_buffer): Fix off-by-one
+--
+
+Depending on the escaping and line wrapping the computed remaining
+buffer length could be wrong. Fixed by always using a break to
+terminate the escape detection loop. Might have happened for all
+status lines which may wrap.
+
+GnuPG-bug-id: T6027
+---
+ g10/cpr.c | 13 ++++---------
+ 1 file changed, 4 insertions(+), 9 deletions(-)
+
+diff --git a/g10/cpr.c b/g10/cpr.c
+index 9bfdd3c34..fa8005d6f 100644
+--- a/g10/cpr.c
++++ b/g10/cpr.c
+@@ -372,20 +372,15 @@ write_status_text_and_buffer (int no, const char *string,
+ }
+ first = 0;
+ }
+- for (esc=0, s=buffer, n=len; n && !esc; s++, n--)
++ for (esc=0, s=buffer, n=len; n; s++, n--)
+ {
+ if (*s == '%' || *(const byte*)s <= lower_limit
+ || *(const byte*)s == 127 )
+ esc = 1;
+ if (wrap && ++count > wrap)
+- {
+- dowrap=1;
+- break;
+- }
+- }
+- if (esc)
+- {
+- s--; n++;
++ dowrap=1;
++ if (esc || dowrap)
++ break;
+ }
+ if (s != buffer)
+ es_fwrite (buffer, s-buffer, 1, statusfp);
+--
+2.11.0
+