summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnome-todo-libportal.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-22 01:11:51 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-22 01:16:23 -0500
commitef451d916460e84a02bbc6eace488a67f02ec85b (patch)
tree8e78513487cb0e086a5709ce8e072afa60aa81cb /gnu/packages/patches/gnome-todo-libportal.patch
parent2b77a66edb54c6e30e7d6073e644cb290dad7a45 (diff)
downloadguix-patches-ef451d916460e84a02bbc6eace488a67f02ec85b.tar
guix-patches-ef451d916460e84a02bbc6eace488a67f02ec85b.tar.gz
gnu: gnome-todo: Update to 41.0 and enable tests.
* gnu/packages/patches/gnome-todo-libportal.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/gnome.scm (gnome-todo): Update to 41.0. [source]: Apply patch. [arguments]: Use G-exp. [tests?]: Delete field, enabling tests. [phases]: Move check phase after install phase. {pre-check}: Add phase. [native-inputs]: Re-style. [inputs]: Likewise. [description]: Re-indent.
Diffstat (limited to 'gnu/packages/patches/gnome-todo-libportal.patch')
-rw-r--r--gnu/packages/patches/gnome-todo-libportal.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnome-todo-libportal.patch b/gnu/packages/patches/gnome-todo-libportal.patch
new file mode 100644
index 0000000000..380c628592
--- /dev/null
+++ b/gnu/packages/patches/gnome-todo-libportal.patch
@@ -0,0 +1,54 @@
+From 3e1f4da8c0e536c09ffaf3b43fe2eb5dc17cc23e Mon Sep 17 00:00:00 2001
+From: Georges Basile Stavracas Neto <georges.stavracas@gmail.com>
+Date: Thu, 18 Nov 2021 19:46:13 -0300
+Subject: [PATCH] flatpak: Adjust to libportal changes
+
+---
+ build-aux/flatpak/org.gnome.Todo.json | 3 +++
+ src/plugins/background/gtd-plugin-background.c | 2 +-
+ src/plugins/background/meson.build | 2 +-
+ 3 files changed, 5 insertions(+), 2 deletions(-)
+
+diff --git a/build-aux/flatpak/org.gnome.Todo.json b/build-aux/flatpak/org.gnome.Todo.json
+index 034e200c..44b83d66 100644
+--- a/build-aux/flatpak/org.gnome.Todo.json
++++ b/build-aux/flatpak/org.gnome.Todo.json
+@@ -143,6 +143,9 @@
+ {
+ "name" : "libportal",
+ "buildsystem" : "meson",
++ "config-opts" : [
++ "-Dbackends=gtk4"
++ ],
+ "sources" : [
+ {
+ "type" : "git",
+diff --git a/src/plugins/background/gtd-plugin-background.c b/src/plugins/background/gtd-plugin-background.c
+index cf48786c..f64d07aa 100644
+--- a/src/plugins/background/gtd-plugin-background.c
++++ b/src/plugins/background/gtd-plugin-background.c
+@@ -28,7 +28,7 @@
+ #include <gtk/gtk.h>
+
+ #include <libportal/portal.h>
+-#include <libportal/portal-gtk4.h>
++#include <libportal-gtk4/portal-gtk4.h>
+
+ #define AUTOSTART_NOTIFICATION_ID "Gtd::BackgroundPlugin::autostart_notification"
+ #define AUTOSTART_NOTIFICATION_TIMEOUT 3 /* seconds */
+diff --git a/src/plugins/background/meson.build b/src/plugins/background/meson.build
+index a671a4f3..59d3635f 100644
+--- a/src/plugins/background/meson.build
++++ b/src/plugins/background/meson.build
+@@ -1,7 +1,7 @@
+ plugins_ldflags += ['-Wl,--undefined=gtd_plugin_background_register_types']
+
+ plugins_deps += [
+- dependency('libportal'),
++ dependency('libportal-gtk4'),
+ ]
+
+ plugins_sources += files(
+--
+GitLab
+