summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gmp-arm-asm-nothumb.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-31 04:17:45 -0500
committerMark H Weaver <mhw@netris.org>2015-01-07 12:34:19 -0500
commit24aaf2f257e6b611d3759ffc53c29828efce1917 (patch)
treeaaf7c0355f43ad403b88037cfe30e348fe66b5e4 /gnu/packages/patches/gmp-arm-asm-nothumb.patch
parent76e639a00fecb194e2fefc267e2e97c5845434b2 (diff)
downloadguix-patches-24aaf2f257e6b611d3759ffc53c29828efce1917.tar
guix-patches-24aaf2f257e6b611d3759ffc53c29828efce1917.tar.gz
gnu: gmp: Apply fixes for armhf.
* gnu/packages/patches/gmp-arm-asm-nothumb.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/multiprecision.scm (gmp): Add patch. Include --build triplet in configure args when building natively. * gnu/packages/commencement.scm (gcc-final): Use bootstrap guile to build gmp-source.
Diffstat (limited to 'gnu/packages/patches/gmp-arm-asm-nothumb.patch')
-rw-r--r--gnu/packages/patches/gmp-arm-asm-nothumb.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/gmp-arm-asm-nothumb.patch b/gnu/packages/patches/gmp-arm-asm-nothumb.patch
new file mode 100644
index 0000000000..666cf58cf6
--- /dev/null
+++ b/gnu/packages/patches/gmp-arm-asm-nothumb.patch
@@ -0,0 +1,21 @@
+
+# HG changeset patch
+# User Torbjorn Granlund <tege@gmplib.org>
+# Date 1396602422 -7200
+# Node ID 676e2d0f0e4dd301a7066079d2c9326c25c34a40
+# Parent 0194a75b56b21a9196626430af86c5bd9110c42d
+Conditionalise ARM asm on !__thumb__.
+
+diff -r 0194a75b56b2 -r 676e2d0f0e4d mpn/generic/div_qr_1n_pi1.c
+--- a/mpn/generic/div_qr_1n_pi1.c Thu Apr 03 23:58:51 2014 +0200
++++ b/mpn/generic/div_qr_1n_pi1.c Fri Apr 04 11:07:02 2014 +0200
+@@ -130,7 +130,7 @@
+ "%2" ((UDItype)(a0)), "r" ((UDItype)(b0)) __CLOBBER_CC)
+ #endif
+
+-#if defined (__arm__) && W_TYPE_SIZE == 32
++#if defined (__arm__) && !defined (__thumb__) && W_TYPE_SIZE == 32
+ #define add_mssaaaa(m, sh, sl, ah, al, bh, bl) \
+ __asm__ ( "adds %2, %5, %6\n\t" \
+ "adcs %1, %3, %4\n\t" \
+