summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-supported-locales.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2018-10-28 11:16:46 +0900
committerMathieu Othacehe <m.othacehe@gmail.com>2018-11-07 18:47:07 +0900
commit1b9fb043d9c2fbd047ab17209ca4a3de5293edee (patch)
tree11ec1ca89fdeaad0de0a25218b37fb55554576f9 /gnu/packages/patches/glibc-supported-locales.patch
parenta036e3c9ba8c303f06e221f14285d265c7b0b4fc (diff)
downloadguix-patches-1b9fb043d9c2fbd047ab17209ca4a3de5293edee.tar
guix-patches-1b9fb043d9c2fbd047ab17209ca4a3de5293edee.tar.gz
gnu: glibc: Export supported locales.
Debian and Archlinux (at least) force the installation of the localedata/SUPPORTED file of the glibc. This file lists all the supported locales of the glibc. * gnu/packages/patches/glibc-supported-locales.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/base.scm (glibc/linux): Add the previous patch, (glibc-2.28): ditto.
Diffstat (limited to 'gnu/packages/patches/glibc-supported-locales.patch')
-rw-r--r--gnu/packages/patches/glibc-supported-locales.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-supported-locales.patch b/gnu/packages/patches/glibc-supported-locales.patch
new file mode 100644
index 0000000000..f1c8a88871
--- /dev/null
+++ b/gnu/packages/patches/glibc-supported-locales.patch
@@ -0,0 +1,31 @@
+This patch is taken from debian's glibc package (generate-supported.mk).
+
+diff --git a/localedata/Makefile.old b/localedata/Makefile
+index 34877c0..a61d9b9 100644
+--- a/localedata/Makefile.old
++++ b/localedata/Makefile
+@@ -91,7 +91,8 @@ endif
+ # Files to install.
+ install-others := $(addprefix $(inst_i18ndir)/, \
+ $(addsuffix .gz, $(charmaps)) \
+- $(locales))
++ $(locales)) \
++ $(inst_i18ndir)/SUPPORTED
+
+ tests: $(objdir)/iconvdata/gconv-modules
+
+@@ -195,6 +196,14 @@ endif
+
+ include SUPPORTED
+
++$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
++ for locale in $(SUPPORTED-LOCALES); do \
++ [ $$locale = true ] && continue; \
++ echo $$locale | sed 's,/, ,' >> LOCALES; \
++ done
++ $(make-target-directory)
++ $(INSTALL_DATA) LOCALES $@
++
+ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
+
+ # Sometimes the whole collection of locale files should be installed.