summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-locales-2.28.patch
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2019-07-04 06:49:29 -0400
committerKei Kebreau <kkebreau@posteo.net>2019-07-09 12:15:52 -0400
commitd4137d84ac75edaf2739578d0868cd77dd6da43c (patch)
treeec389b86ea454880ba4494c97691314018a23c3a /gnu/packages/patches/glibc-locales-2.28.patch
parentca3757e1c2fdc1576d17239a57f0a493a47bc6dc (diff)
downloadguix-patches-d4137d84ac75edaf2739578d0868cd77dd6da43c.tar
guix-patches-d4137d84ac75edaf2739578d0868cd77dd6da43c.tar.gz
gnu: make-glibc-locales: Adjust patch for glibc 2.29.
The patch for glibc 2.28 and earlier replaces the same content, but the context in the patch is different enough to fail to merge. * gnu/packages/base.scm (make-glibc-locales)[source]: Add patch. * gnu/packages/patches/glibc-locales.patch: Adjust for glibc 2.29 and move old file... * gnu/packages/patches/glibc-locales-2.28.patch: ...here. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/glibc-locales-2.28.patch')
-rw-r--r--gnu/packages/patches/glibc-locales-2.28.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-locales-2.28.patch b/gnu/packages/patches/glibc-locales-2.28.patch
new file mode 100644
index 0000000000..31ee6c1ff3
--- /dev/null
+++ b/gnu/packages/patches/glibc-locales-2.28.patch
@@ -0,0 +1,31 @@
+This patch allows us to use glibc's build system to build locales
+in a package separate from glibc.
+
+ 1. Use 'localedef' from $PATH since we are not rebuilding it.
+ 2. Use '--no-archive' to avoid building the big locale archive, and
+ because the already-built 'localedef' would want to write it
+ to '/run/current-system/locale', which is not possible.
+ 3. Pass $(inst_complocaledir)/$$locale to install files in the right
+ place, and because otherwise, 'localedef' fails with:
+ "cannot write output files to `(null)'".
+
+--- glibc-2.27/localedata/Makefile
++++ glibc-2.27/localedata/Makefile
+@@ -199,7 +199,7 @@ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
+
+ # Sometimes the whole collection of locale files should be installed.
+ LOCALEDEF=I18NPATH=. GCONV_PATH=$(common-objpfx)iconvdata LC_ALL=C \
+-$(rtld-prefix) $(common-objpfx)locale/localedef
++ localedef --no-archive
+ install-locales: $(INSTALL-SUPPORTED-LOCALES)
+
+ install-locales-dir:
+@@ -224,7 +224,7 @@ $(INSTALL-SUPPORTED-LOCALES): install-locales-dir
+ input=`echo $$locale | sed 's/\([^.]*\)[^@]*\(.*\)/\1\2/'`; \
+ $(LOCALEDEF) $$flags --alias-file=../intl/locale.alias \
+ -i locales/$$input -f charmaps/$$charset \
+- $(addprefix --prefix=,$(install_root)) $$locale \
++ $(addprefix --prefix=,$(install_root)) $(inst_complocaledir)/$$locale \
+ && echo ' done'; \
+
+ tst-setlocale-ENV = LC_ALL=ja_JP.EUC-JP