summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-bootstrap-system.patch
diff options
context:
space:
mode:
authorFranz Josef <guix.riscv@gmail.com>2021-07-25 15:12:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-28 16:05:31 +0300
commit7d93b21ab1c132990054372a9677c1639d54e631 (patch)
tree2db3b3db07643114eab7b6a3fcc3021fbc213b30 /gnu/packages/patches/glibc-bootstrap-system.patch
parent8afd85538a6a1ec1c6fe096c5f994f6ba8cac50c (diff)
downloadguix-patches-7d93b21ab1c132990054372a9677c1639d54e631.tar
guix-patches-7d93b21ab1c132990054372a9677c1639d54e631.tar.gz
gnu: glibc-for-bootstrap: Update patch.
There was/is something funny going on with the bootstrap glibc. The symbol for posix_spawnp points to getopt_r. Which in turn leads to a lot of crashed in tests later on. I extended the glibc-bootstrap patch to work around this bug. * gnu/packages/patches/glibc-bootstrap-system.patch: Adjust patch to work correctly with new architectures. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches/glibc-bootstrap-system.patch')
-rw-r--r--gnu/packages/patches/glibc-bootstrap-system.patch27
1 files changed, 25 insertions, 2 deletions
diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
index 39eb47ef26..db6457e939 100644
--- a/gnu/packages/patches/glibc-bootstrap-system.patch
+++ b/gnu/packages/patches/glibc-bootstrap-system.patch
@@ -10,7 +10,7 @@ instead uses the hard-coded absolute file name of `bash'.
POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
- status = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
-+ status = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
++ status = __posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
(char *const[]){ (char*) SHELL_NAME,
(char*) "-c",
(char *) line, NULL },
@@ -21,8 +21,31 @@ instead uses the hard-coded absolute file name of `bash'.
}
- if (__posix_spawn (&((_IO_proc_file *) fp)->pid, _PATH_BSHELL, fa, 0,
-+ if (posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
++ if (__posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
(char *const[]){ (char*) "sh", (char*) "-c",
(char *) command, NULL }, __environ) != 0)
return false;
+--- a/include/spawn.h
++++ b/include/spawn.h
+@@ -5,6 +5,9 @@
+ __typeof (posix_spawn) __posix_spawn;
+ libc_hidden_proto (__posix_spawn)
+
++__typeof (posix_spawnp) __posix_spawnp;
++libc_hidden_proto (__posix_spawnp)
++
+ __typeof (posix_spawn_file_actions_addclose)
+ __posix_spawn_file_actions_addclose attribute_hidden;
+
+--- a/posix/spawnp.c
++++ b/posix/spawnp.c
+@@ -31,6 +31,7 @@ __posix_spawnp (pid_t *pid, const char *file,
+ SPAWN_XFLAGS_USE_PATH);
+ }
+ versioned_symbol (libc, __posix_spawnp, posix_spawnp, GLIBC_2_15);
++libc_hidden_def (__posix_spawnp)
+
+
+ #if SHLIB_COMPAT (libc, GLIBC_2_2, GLIBC_2_15)
+