summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-bootstrap-system.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 16:45:17 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 16:45:17 +0200
commit5f3f70391809f8791c55c05bd1646bc58508fa2c (patch)
tree17d52b40817be205a93f392cf002494e3a9d7e5c /gnu/packages/patches/glibc-bootstrap-system.patch
parent1290855490baf03944dc85d8353c2b8cedac5256 (diff)
downloadguix-patches-5f3f70391809f8791c55c05bd1646bc58508fa2c.tar
guix-patches-5f3f70391809f8791c55c05bd1646bc58508fa2c.tar.gz
gnu: glibc: Update to 2.29.
* gnu/packages/patches/glibc-bootstrap-system.patch, gnu/packages/patches/glibc-supported-locales.patch: Adjust for glibc 2.29. * gnu/packages/patches/glibc-2.28-supported-locales.patch, gnu/packages/patches/glibc-CVE-2019-7309.patch, gnu/packages/patches/glibc-CVE-2019-9169.patch, gnu/packages/patches/glibc-2.29-git-updates.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/base.scm (glibc): Update to 2.29. [source](patches): Add 'glibc-CVE-2019-7309.patch', 'glibc-CVE-2019-9169.patch', and 'glibc-2.29-git-updates.patch'. Remove 'glibc-hurd-magic-pid.patch'. [native-inputs]: Add PYTHON-MINIMAL. (glibc-2.28): New public variable. * gnu/packages/commencement.scm (expat-sans-tests, python-boot0): New variables. (glibc-final-with-bootstrap-bash)[native-inputs]: Add PYTHON-BOOT0. * gnu/packages/python.scm (python-3.7)[arguments]: Disable test that fails with glibc 2.29.
Diffstat (limited to 'gnu/packages/patches/glibc-bootstrap-system.patch')
-rw-r--r--gnu/packages/patches/glibc-bootstrap-system.patch34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
index addeed6dbd..39eb47ef26 100644
--- a/gnu/packages/patches/glibc-bootstrap-system.patch
+++ b/gnu/packages/patches/glibc-bootstrap-system.patch
@@ -5,26 +5,24 @@ instead uses the hard-coded absolute file name of `bash'.
--- a/sysdeps/posix/system.c
+++ b/sysdeps/posix/system.c
-@@ -134,7 +134,7 @@ do_system (const char *line)
- INIT_LOCK ();
+@@ -140,7 +140,7 @@ do_system (const char *line)
+ __posix_spawnattr_setflags (&spawn_attr,
+ POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
- /* Exec the shell. */
-- (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
-+ (void) __execvpe (SHELL_NAME, (char *const *) new_argv, __environ);
- _exit (127);
- }
- else if (pid < (pid_t) 0)
-
+- status = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
++ status = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
+ (char *const[]){ (char*) SHELL_NAME,
+ (char*) "-c",
+ (char *) line, NULL },
--- a/libio/iopopen.c
+++ b/libio/iopopen.c
-@@ -145,7 +145,7 @@ _IO_new_proc_open (fp, command, mode)
- __close_nocancel (fd);
- }
-
-- execl ("/bin/sh", "sh", "-c", command, (char *) 0);
-+ execlp ("sh", "sh", "-c", command, (char *) 0);
- _exit (127);
+@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
+ return false;
}
- __close_nocancel (child_end);
-
+
+- if (__posix_spawn (&((_IO_proc_file *) fp)->pid, _PATH_BSHELL, fa, 0,
++ if (posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
+ (char *const[]){ (char*) "sh", (char*) "-c",
+ (char *) command, NULL }, __environ) != 0)
+ return false;