summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-bootstrap-system.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-25 02:31:49 -0400
committerMark H Weaver <mhw@netris.org>2018-03-25 05:02:00 -0400
commit06b1d6954aa6cf7123745136df41bc949b591f1c (patch)
treeb52174ad04a8c131b754f9db7b5d937207deb852 /gnu/packages/patches/glibc-bootstrap-system.patch
parent0bc7c2e43da7aac5f9fab1ffb4c095bc8397ecfa (diff)
downloadguix-patches-06b1d6954aa6cf7123745136df41bc949b591f1c.tar
guix-patches-06b1d6954aa6cf7123745136df41bc949b591f1c.tar.gz
gnu: make-bootstrap: Adapt glibc-bootstrap-system.patch for glibc-2.27.
* gnu/packages/patches/glibc-bootstrap-system.patch: Adapt for glibc-2.27.
Diffstat (limited to 'gnu/packages/patches/glibc-bootstrap-system.patch')
-rw-r--r--gnu/packages/patches/glibc-bootstrap-system.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/glibc-bootstrap-system.patch b/gnu/packages/patches/glibc-bootstrap-system.patch
index 2f8e7da7e1..addeed6dbd 100644
--- a/gnu/packages/patches/glibc-bootstrap-system.patch
+++ b/gnu/packages/patches/glibc-bootstrap-system.patch
@@ -15,16 +15,16 @@ instead uses the hard-coded absolute file name of `bash'.
}
else if (pid < (pid_t) 0)
---- b/libio/iopopen.c 2012-06-30 21:12:34.000000000 +0200
-+++ b/libio/iopopen.c 2012-12-19 12:52:29.000000000 +0100
-@@ -226,7 +226,7 @@ _IO_new_proc_open (fp, command, mode)
- _IO_close (fd);
+--- a/libio/iopopen.c
++++ b/libio/iopopen.c
+@@ -145,7 +145,7 @@ _IO_new_proc_open (fp, command, mode)
+ __close_nocancel (fd);
}
-- _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
+- execl ("/bin/sh", "sh", "-c", command, (char *) 0);
+ execlp ("sh", "sh", "-c", command, (char *) 0);
- _IO__exit (127);
+ _exit (127);
}
- _IO_close (child_end);
+ __close_nocancel (child_end);