summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/glibc-2.27-supported-locales.patch
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2019-07-08 21:20:17 -0400
committerCarl Dong <contact@carldong.me>2019-07-08 21:20:17 -0400
commitca3757e1c2fdc1576d17239a57f0a493a47bc6dc (patch)
tree0e4e7e868bf448f935821284828834f9b16ea0e0 /gnu/packages/patches/glibc-2.27-supported-locales.patch
parentbcfc54fff80ef6a11fc53c61db333a8065bbfeef (diff)
downloadguix-patches-ca3757e1c2fdc1576d17239a57f0a493a47bc6dc.tar
guix-patches-ca3757e1c2fdc1576d17239a57f0a493a47bc6dc.tar.gz
gnu: glibc: Add 2.27 supported locales patch.
The 'glibc-supported-locales.patch' was updated for glibc 2.29, breaking compatibility with 2.27. Add a 2.27-specific supported locales patch. * gnu/packages/patches/glibc-2.27-supported-locales.patch: New file. * gnu/packages/base.scm (glibc-2.27)[source](patches): Use 'glibc-2.27-supported-locales.patch' instead. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/glibc-2.27-supported-locales.patch')
-rw-r--r--gnu/packages/patches/glibc-2.27-supported-locales.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/patches/glibc-2.27-supported-locales.patch b/gnu/packages/patches/glibc-2.27-supported-locales.patch
new file mode 100644
index 0000000000..2888052bb8
--- /dev/null
+++ b/gnu/packages/patches/glibc-2.27-supported-locales.patch
@@ -0,0 +1,33 @@
+This patch is taken from debian's glibc package (generate-supported.mk).
+It install the localedata/SUPPORTED file of the glibc. This file lists
+all the supported locales of the glibc.
+
+diff --git a/localedata/Makefile.old b/localedata/Makefile
+index 34877c0..a61d9b9 100644
+--- a/localedata/Makefile.old
++++ b/localedata/Makefile
+@@ -91,7 +91,8 @@ endif
+ # Files to install.
+ install-others := $(addprefix $(inst_i18ndir)/, \
+ $(addsuffix .gz, $(charmaps)) \
+- $(locales))
++ $(locales)) \
++ $(inst_i18ndir)/SUPPORTED
+
+ tests: $(objdir)/iconvdata/gconv-modules
+
+@@ -195,6 +196,14 @@ endif
+
+ include SUPPORTED
+
++$(inst_i18ndir)/SUPPORTED: SUPPORTED $(+force)
++ for locale in $(SUPPORTED-LOCALES); do \
++ [ $$locale = true ] && continue; \
++ echo $$locale | sed 's,/, ,' >> LOCALES; \
++ done
++ $(make-target-directory)
++ $(INSTALL_DATA) LOCALES $@
++
+ INSTALL-SUPPORTED-LOCALES=$(addprefix install-, $(SUPPORTED-LOCALES))
+
+ # Sometimes the whole collection of locale files should be installed.