summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ghostscript-no-header-creationdate.patch
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-07-10 01:28:34 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2017-07-10 18:20:32 +0200
commitad22c7185395a52bd90ea5890a2ac79f44d00352 (patch)
treea9741781fe37b88c01b567739f230126d95fc298 /gnu/packages/patches/ghostscript-no-header-creationdate.patch
parent63eb4a2a91af8d0a3801bb542f73fd21ecfc9a9e (diff)
downloadguix-patches-ad22c7185395a52bd90ea5890a2ac79f44d00352.tar
guix-patches-ad22c7185395a52bd90ea5890a2ac79f44d00352.tar.gz
gnu: ghostscript: Make "/CreationDate", "/ModDate" optional, depending on environment variable.
* gnu/packages/patches/ghostscript-no-header-creationdate.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ghostscript.scm (ghostscript): Use it.
Diffstat (limited to 'gnu/packages/patches/ghostscript-no-header-creationdate.patch')
-rw-r--r--gnu/packages/patches/ghostscript-no-header-creationdate.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghostscript-no-header-creationdate.patch b/gnu/packages/patches/ghostscript-no-header-creationdate.patch
new file mode 100644
index 0000000000..92ddbdade0
--- /dev/null
+++ b/gnu/packages/patches/ghostscript-no-header-creationdate.patch
@@ -0,0 +1,22 @@
+This patch makes emission of /CreationDate and /ModDate headers optional.
+
+If the environment variable GS_GENERATE_UUIDS is set to "0" or "no", it will
+not write out the "/ID" field (if that's permissible).
+
+Upstream does not want to do this.
+
+See: https://bugs.ghostscript.com/show_bug.cgi?id=698208
+diff --git a/orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c b/bb/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
+index 0fb067e..b342e2c 100644
+--- orig/gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
++++ gnu-ghostscript-9.14.0/devices/vector/gdevpdf.c
+@@ -305,6 +305,9 @@ pdf_initialize_ids(gx_device_pdf * pdev)
+ * date and time, rather than (for example) %%CreationDate from the
+ * PostScript file. We think this is wrong, but we do the same.
+ */
++ if (!getenv("GS_GENERATE_UUIDS") ||
++ (strcasecmp(getenv("GS_GENERATE_UUIDS"), "0") != 0 &&
++ strcasecmp(getenv("GS_GENERATE_UUIDS"), "no") != 0))
+ {
+ struct tm tms;
+ time_t t;