summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch
diff options
context:
space:
mode:
authorJosselin Poiret <josselin.poiret@protonmail.ch>2021-09-13 07:45:06 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 17:17:44 +0000
commit5c3f0c3e03757b6653f4c2386a526a2d9d6532f7 (patch)
tree198208aa5bf83200d37abee56ce724e2b78d8ea4 /gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch
parentfc24bcb86fb68e1e69c168d5de7d94f01148c9cd (diff)
downloadguix-patches-5c3f0c3e03757b6653f4c2386a526a2d9d6532f7.tar
guix-patches-5c3f0c3e03757b6653f4c2386a526a2d9d6532f7.tar.gz
gnu: Add Wayland support for GDM.
Add the optional flag `wayland?` in `gdm-configuration` to launch GDM with Wayland, enabling the use of Wayland sessions with GDM. * gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gnome.scm (gdm): Use it. * gnu/services/xorg.scm (<gdm-configuration>)[wayland?]: New field. (gdm-configuration): Honor it. (gdm-shepherd-service): Add the XCURSOR_PATH environment variable. * doc/guix.texi (X Window): Document it Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch')
-rw-r--r--gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch b/gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch
new file mode 100644
index 0000000000..366fb91668
--- /dev/null
+++ b/gnu/packages/patches/gdm-remove-hardcoded-xwayland-path.patch
@@ -0,0 +1,22 @@
+Remove check for hardcoded Xwayland path in gdm.
+
+---
+ daemon/gdm-local-display-factory.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/daemon/gdm-local-display-factory.c b/daemon/gdm-local-display-factory.c
+index da1093bb..37355c06 100644
+--- a/daemon/gdm-local-display-factory.c
++++ b/daemon/gdm-local-display-factory.c
+@@ -203,7 +203,7 @@ gdm_local_display_factory_use_wayland (void)
+ #ifdef ENABLE_WAYLAND_SUPPORT
+ gboolean wayland_enabled = FALSE;
+ if (gdm_settings_direct_get_boolean (GDM_KEY_WAYLAND_ENABLE, &wayland_enabled)) {
+- if (wayland_enabled && g_file_test ("/usr/bin/Xwayland", G_FILE_TEST_IS_EXECUTABLE) )
++ if (wayland_enabled)
+ return TRUE;
+ }
+ #endif
+--
+2.33.0
+