summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gcc-cross-environment-variables.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-05-24 21:54:44 +0200
committerLudovic Courtès <ludo@gnu.org>2013-05-24 21:54:44 +0200
commit248d08ebf0f2333d13c36358a4e1556c7114048b (patch)
treebdcf14c9d4782acc47d3d7c082c94d2264fbda3f /gnu/packages/patches/gcc-cross-environment-variables.patch
parenta63062b55a6592467816571fd7983f4e88903c0a (diff)
downloadguix-patches-248d08ebf0f2333d13c36358a4e1556c7114048b.tar
guix-patches-248d08ebf0f2333d13c36358a4e1556c7114048b.tar.gz
gnu: cross-gcc: Change patch so that `CROSS_LIBRARY_PATH' is honored.
* gnu/packages/patches/gcc-cross-environment-variables.patch: Add two hunks, most notably one that changes GCC to honor LIBRARY_PATH_ENV when cross-compiling.
Diffstat (limited to 'gnu/packages/patches/gcc-cross-environment-variables.patch')
-rw-r--r--gnu/packages/patches/gcc-cross-environment-variables.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/gcc-cross-environment-variables.patch b/gnu/packages/patches/gcc-cross-environment-variables.patch
index 30a07ec3db..0bd0be5984 100644
--- a/gnu/packages/patches/gcc-cross-environment-variables.patch
+++ b/gnu/packages/patches/gcc-cross-environment-variables.patch
@@ -22,3 +22,27 @@ at <http://gcc.gnu.org/ml/gcc/2013-02/msg00124.html>.
+#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH"
+
#endif /* ! GCC_SYSTEM_H */
+
+--- gcc-4.7.2/gcc/tlink.c 2012-02-11 09:50:23.000000000 +0100
++++ gcc-4.7.2/gcc/tlink.c 2013-05-23 22:06:19.000000000 +0200
+@@ -461,7 +461,7 @@ recompile_files (void)
+ file *f;
+
+ putenv (xstrdup ("COMPILER_PATH="));
+- putenv (xstrdup ("LIBRARY_PATH="));
++ putenv (xstrdup (LIBRARY_PATH_ENV "="));
+
+ while ((f = file_pop ()) != NULL)
+ {
+
+--- gcc-4.7.3/gcc/gcc.c 2013-03-08 08:25:09.000000000 +0100
++++ gcc-4.7.3/gcc/gcc.c 2013-05-24 08:58:16.000000000 +0200
+@@ -3726,7 +3726,7 @@ process_command (unsigned int decoded_op
+ }
+
+ temp = getenv (LIBRARY_PATH_ENV);
+- if (temp && *cross_compile == '0')
++ if (temp)
+ {
+ const char *startp, *endp;
+ char *nstore = (char *) alloca (strlen (temp) + 3);