summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gawk-shell.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-09 21:38:00 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-09 22:32:15 +0200
commite58652502b652f5dbc0fa53ed32beac2a0cd09a2 (patch)
tree884232063b4d4345b62086d0c859f166443c3469 /gnu/packages/patches/gawk-shell.patch
parent30347caae78d200573554d9e3734efc9ccc37d9c (diff)
downloadguix-patches-e58652502b652f5dbc0fa53ed32beac2a0cd09a2.tar
guix-patches-e58652502b652f5dbc0fa53ed32beac2a0cd09a2.tar.gz
gnu: make-bootstrap: Adjust gawk patch to 4.1.3.
* gnu/packages/patches/gawk-shell.patch: Update for gawk 4.1.3.
Diffstat (limited to 'gnu/packages/patches/gawk-shell.patch')
-rw-r--r--gnu/packages/patches/gawk-shell.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/patches/gawk-shell.patch b/gnu/packages/patches/gawk-shell.patch
index 89b8540a8d..80e9c65475 100644
--- a/gnu/packages/patches/gawk-shell.patch
+++ b/gnu/packages/patches/gawk-shell.patch
@@ -2,9 +2,9 @@ As for libc's `system', change Awk to look for `sh' in $PATH. This patch is
only meant to be used during bootstrapping, where we don't know in advance the
absolute file name of `sh'.
---- gawk-4.0.0/io.c 2011-05-18 20:47:29.000000000 +0200
-+++ gawk-4.0.0/io.c 2012-12-18 15:56:06.000000000 +0100
-@@ -1759,7 +1759,7 @@ two_way_open(const char *str, struct red
+--- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200
++++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200
+@@ -1945,7 +1945,7 @@ two_way_open(const char *str, struct red
signal(SIGPIPE, SIG_DFL);
@@ -13,22 +13,22 @@ absolute file name of `sh'.
_exit(errno == ENOENT ? 127 : 126);
case -1:
-@@ -1924,7 +1924,7 @@ use_pipes:
- || close(ctop[0]) == -1 || close(ctop[1]) == -1)
+@@ -2129,7 +2129,7 @@ use_pipes:
fatal(_("close of pipe failed (%s)"), strerror(errno));
/* stderr does NOT get dup'ed onto child's stdout */
+ signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", str, NULL);
+ execlp("sh", "sh", "-c", str, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
- #endif /* NOT __EMX__ */
-@@ -2074,7 +2074,7 @@ gawk_popen(const char *cmd, struct redir
- fatal(_("moving pipe to stdout in child failed (dup: %s)"), strerror(errno));
+ #endif /* NOT __EMX__, NOT __MINGW32__ */
+@@ -2323,7 +2323,7 @@ gawk_popen(const char *cmd, struct redir
if (close(p[0]) == -1 || close(p[1]) == -1)
fatal(_("close of pipe failed (%s)"), strerror(errno));
+ signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", cmd, NULL);
+ execlp("sh", "sh", "-c", cmd, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
- #endif /* NOT __EMX__ */
+ #endif /* NOT __EMX__, NOT __MINGW32__ */