summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 15:20:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-19 22:16:18 +0100
commitc18803f28dce7f9beb2c81aead253d86b05618e7 (patch)
treea24195ca081943ecd5ed241904437efff2e5d579 /gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
parentaa954ec3664738f3d7b75a5ba96f787b93ad50c8 (diff)
downloadguix-patches-c18803f28dce7f9beb2c81aead253d86b05618e7.tar
guix-patches-c18803f28dce7f9beb2c81aead253d86b05618e7.tar.gz
gnu: gajim: Honour $GAJIM_PLUGIN_PATH.
This allows Gajim to find plug-ins installed with Guix. Reported at <http://issues.guix.gnu.org/44730>. However, at the time of pushing both packaged plug-ins (gajim-omemo and gajim-openpgp) require an unstable version of Gajim and will not load. * gnu/packages/messaging.scm (gajim)[arguments]: Replace the ‘add-plugin-dirs’ substitution phase with a... [source]: ...patch that won't silently break in the future. * gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch')
-rw-r--r--gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
new file mode 100644
index 0000000000..cb3313197c
--- /dev/null
+++ b/gnu/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch
@@ -0,0 +1,11 @@
+--- a/gajim/common/configpaths.py 2020-11-19 12:12:02.004414323 +0100
++++ a/gajim/common/configpaths.py 2020-11-19 15:34:52.211476895 +0100
+@@ -47,7 +47,7 @@
+ return [Path(_paths['PLUGINS_BASE']),
+ Path('/app/plugins')]
+ return [Path(_paths['PLUGINS_BASE']),
+- Path(_paths['PLUGINS_USER'])]
++ Path(_paths['PLUGINS_USER'])] + ([Path(os.getenv('GAJIM_PLUGIN_PATH'))] if os.getenv('GAJIM_PLUGIN_PATH') and Path(os.getenv('GAJIM_PLUGIN_PATH')).is_dir() else [])
+
+
+ def get_paths(type_: PathType) -> Generator[str, None, None]: