summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fontconfig-hurd-path-max.patch
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-08 20:07:24 -0400
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-26 12:59:33 +0100
commit9dd9e8fabfd0b3f3d11e8e26a7aa13d1b0ceea49 (patch)
tree9f383bc3a08415cfc791fe6d7f3b89d61ded3cc8 /gnu/packages/patches/fontconfig-hurd-path-max.patch
parent7baa8c78983424497f5db522243e9e396c99eb12 (diff)
downloadguix-patches-9dd9e8fabfd0b3f3d11e8e26a7aa13d1b0ceea49.tar
guix-patches-9dd9e8fabfd0b3f3d11e8e26a7aa13d1b0ceea49.tar.gz
gnu: fontconfig: Build fix for the Hurd.
* gnu/packages/patches/fontconfig-hurd-path-max.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/fontutils.scm (fontconfig): Use it.
Diffstat (limited to 'gnu/packages/patches/fontconfig-hurd-path-max.patch')
-rw-r--r--gnu/packages/patches/fontconfig-hurd-path-max.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/fontconfig-hurd-path-max.patch b/gnu/packages/patches/fontconfig-hurd-path-max.patch
new file mode 100644
index 0000000000..f804e6801f
--- /dev/null
+++ b/gnu/packages/patches/fontconfig-hurd-path-max.patch
@@ -0,0 +1,17 @@
+Avoid usage of PATH_MAX.
+
+Taken from https://salsa.debian.org/freedesktop-team/fontconfig/-/blob/master/debian/patches/path_max.patch
+
+Index: fontconfig-2.13.1/src/fccfg.c
+===================================================================
+--- fontconfig-2.13.1.orig/src/fccfg.c
++++ fontconfig-2.13.1/src/fccfg.c
+@@ -2231,7 +2231,7 @@ FcConfigRealFilename (FcConfig *config,
+
+ if (n)
+ {
+- FcChar8 buf[PATH_MAX];
++ FcChar8 buf[FC_PATH_MAX];
+ ssize_t len;
+
+ if (sysroot)