summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/findutils-test-rwlock-threads.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-14 17:56:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-14 18:31:34 +0100
commitf87b68a18627fe8bab960d45460dd2217fa85def (patch)
tree3ea3923b35a4bbc7942827b7ab1a1fe87d69cd30 /gnu/packages/patches/findutils-test-rwlock-threads.patch
parent0bcc1b14fc3e2382406b97577c56e2292b96b8d4 (diff)
downloadguix-patches-f87b68a18627fe8bab960d45460dd2217fa85def.tar
guix-patches-f87b68a18627fe8bab960d45460dd2217fa85def.tar.gz
gnu: findutils: Fix bootstrap on aarch64-linux and armhf-linux.
* gnu/packages/patches/findutils-test-rwlock-threads.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/base.scm (findutils)[source](patches): Add it.
Diffstat (limited to 'gnu/packages/patches/findutils-test-rwlock-threads.patch')
-rw-r--r--gnu/packages/patches/findutils-test-rwlock-threads.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patches/findutils-test-rwlock-threads.patch b/gnu/packages/patches/findutils-test-rwlock-threads.patch
new file mode 100644
index 0000000000..3062577c21
--- /dev/null
+++ b/gnu/packages/patches/findutils-test-rwlock-threads.patch
@@ -0,0 +1,38 @@
+Skip "test-rwlock1" when multithreading is disabled, which is the case
+during bootstrapping on architectures not supported by GNU Mes.
+
+Taken from upstream gnulib:
+https://git.savannah.gnu.org/cgit/gnulib.git/commit/?id=fdff8bd09a7f053381f8bdb107ab5280b7c95959
+
+diff --git a/gnulib-tests/test-rwlock1.c b/gnulib-tests/test-rwlock1.c
+--- a/gnulib-tests/test-rwlock1.c
++++ b/gnulib-tests/test-rwlock1.c
+@@ -21,6 +21,8 @@
+
+ #include <config.h>
+
++#if USE_ISOC_THREADS || USE_POSIX_THREADS || USE_ISOC_AND_POSIX_THREADS || USE_WINDOWS_THREADS
++
+ #include "glthread/lock.h"
+
+ #include <errno.h>
+@@ -151,3 +153,18 @@ main ()
+ sleep (1);
+ }
+ }
++
++#else
++
++/* No multithreading available. */
++
++#include <stdio.h>
++
++int
++main ()
++{
++ fputs ("Skipping test: multithreading not enabled\n", stderr);
++ return 77;
++}
++
++#endif
+