summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch
diff options
context:
space:
mode:
authorFis Trivial <ybbs.daans@hotmail.com>2018-05-28 08:10:26 +0000
committerLudovic Courtès <ludo@gnu.org>2018-05-28 13:48:52 +0200
commit385357c0d7ebdb7102133095de1667f43ad00116 (patch)
treede4e65fb3f330bce9f65f8ef561027076a8d1a3e /gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch
parentad8a4d6dc8de0576640ff78b4f3e4307ec9fa25c (diff)
downloadguix-patches-385357c0d7ebdb7102133095de1667f43ad00116.tar
guix-patches-385357c0d7ebdb7102133095de1667f43ad00116.tar.gz
gnu: Add fifo-map.
* gnu/packages/cpp.scm (fifo-map): New variable. * gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch: New file. * gnu/packages/patches/fifo-map-remove-catch.hpp.patch: New file. * gnu/local.mk: Add new patch files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch')
-rw-r--r--gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch b/gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch
new file mode 100644
index 0000000000..59b7105220
--- /dev/null
+++ b/gnu/packages/patches/fifo-map-fix-flags-for-gcc.patch
@@ -0,0 +1,39 @@
+From 0871db30bd73d112a434f54572d34cca28de61c5 Mon Sep 17 00:00:00 2001
+From: fis <ybbs.daans@hotmail.com>
+Date: Sat, 26 May 2018 22:58:37 +0800
+Subject: [PATCH 2/2] * CMakeLists.txt: Fix flags for gcc.
+
+---
+ CMakeLists.txt | 18 ++----------------
+ 1 file changed, 2 insertions(+), 16 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index eba147b..d60dcef 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,20 +6,6 @@ add_executable(unit src/fifo_map.hpp test/unit.cpp)
+
+ target_include_directories(unit PRIVATE "test" "src")
+
+-if(MSVC)
+- set(CMAKE_CXX_FLAGS
+- "/EHsc"
+- )
++set(CMAKE_CXX_FLAGS "-std=c++11 -fpermissive")
+
+- STRING(REPLACE "/O2" "/Od" CMAKE_CXX_FLAGS_RELEASE ${CMAKE_CXX_FLAGS_RELEASE})
+-
+- add_definitions(-D_SCL_SECURE_NO_WARNINGS)
+-else(MSVC)
+- set(CMAKE_CXX_FLAGS
+- "-std=c++11 -stdlib=libc++"
+- )
+-endif(MSVC)
+-
+-include_directories(
+- src test
+-)
++include_directories(src test)
+--
+2.14.3
+