summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/evilwm-lost-focus-bug.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-10-22 17:41:39 -0500
committerEric Bavier <bavier@member.fsf.org>2015-10-22 17:47:37 -0500
commitc595cd47d8d60688f8eb56f25baab2854880e43c (patch)
treeb5e0aeb2aa4aba2233f76f3085c9a0a1593edf2e /gnu/packages/patches/evilwm-lost-focus-bug.patch
parent2442e69e4182b592757dad473c8c7b1c48ca8284 (diff)
downloadguix-patches-c595cd47d8d60688f8eb56f25baab2854880e43c.tar
guix-patches-c595cd47d8d60688f8eb56f25baab2854880e43c.tar.gz
gnu: evilwm: Add patch for lost-focus bug.
* gnu/packages/patches/evilwm-lost-focus-bug.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/wm.scm (evilwm)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/evilwm-lost-focus-bug.patch')
-rw-r--r--gnu/packages/patches/evilwm-lost-focus-bug.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/evilwm-lost-focus-bug.patch b/gnu/packages/patches/evilwm-lost-focus-bug.patch
new file mode 100644
index 0000000000..af24af8fe9
--- /dev/null
+++ b/gnu/packages/patches/evilwm-lost-focus-bug.patch
@@ -0,0 +1,18 @@
+evilwm may sometimes lose focus after closing a window. This means that
+evilwm stops responding to keyboard shortcuts, and if no other window is open
+which the mouse can be moved over to regain focus evilwm becomes unusable and
+has to be restarted.
+
+Patch derived from discussion at
+https://wiki.archlinux.org/index.php/Evilwm#Lost_focus_bug_fix
+
+--- evilwm-1.1.1/client.c
++++ evilwm-1.1.1/client.c
+@@ -172,6 +172,7 @@
+ * _NET_WM_STATE) */
+ if (c->remove) {
+ LOG_DEBUG("setting WithdrawnState\n");
++ XSetInputFocus(dpy, PointerRoot, RevertToPointerRoot, CurrentTime);
+ set_wm_state(c, WithdrawnState);
+ ewmh_withdraw_client(c);
+ } else {