summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/erlang-man-path.patch
diff options
context:
space:
mode:
authorPeter Mikkelsen <petermikkelsen10@gmail.com>2017-07-29 17:06:55 +0200
committerLudovic Courtès <ludo@gnu.org>2017-07-29 23:03:47 +0200
commita4078acf4ab7d694e86ffcaef2073d71e58508f1 (patch)
treea78a691674205eee8cdc7b64baef59b6abc68758 /gnu/packages/patches/erlang-man-path.patch
parent53ac6977ac0bbd766d014d3b0aefea3958bbf54f (diff)
downloadguix-patches-a4078acf4ab7d694e86ffcaef2073d71e58508f1.tar
guix-patches-a4078acf4ab7d694e86ffcaef2073d71e58508f1.tar.gz
gnu: erlang: Fix man-pages search path of 'erl -man'.
* gnu/packages/patches/erlang-man-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/erlang.scm (erlang)[source]: Use it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/erlang-man-path.patch')
-rw-r--r--gnu/packages/patches/erlang-man-path.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/erlang-man-path.patch b/gnu/packages/patches/erlang-man-path.patch
new file mode 100644
index 0000000000..68fc9f45b4
--- /dev/null
+++ b/gnu/packages/patches/erlang-man-path.patch
@@ -0,0 +1,24 @@
+Patch originally from https://sources.debian.net/patches/erlang/1:20.0.1%2Bdfsg-2/man.patch/
+by Francois-Denis Gonthier <neumann@lostwebsite.net>.
+
+Patch description rewritten for Guix.
+
+This patch allows access to the man page with the 'erl -man' command
+(Erlang manual pages are placed to /gnu/store/..erlang../share/man/ hierarchy
+as other man pages.)
+
+--- a/erts/etc/common/erlexec.c
++++ b/erts/etc/common/erlexec.c
+@@ -709,8 +709,10 @@
+ error("-man not supported on Windows");
+ #else
+ argv[i] = "man";
+- erts_snprintf(tmpStr, sizeof(tmpStr), "%s/man", rootdir);
+- set_env("MANPATH", tmpStr);
++ /*
++ * Conform to erlang-manpages content.
++ */
++ putenv(strsave("MANSECT=1:3:5:7"));
+ execvp("man", argv+i);
+ error("Could not execute the 'man' command.");
+ #endif