summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-26 11:45:16 +0300
committerAlex Kost <alezost@gmail.com>2016-05-30 13:09:43 +0300
commit4509ec72a4f7034e9a7087e802a84bbe04f4c12c (patch)
tree4c0976aa15ec9f05d75e6ffe0968bdf081384ef2 /gnu/packages/patches/emacs-fix-scheme-indent-function.patch
parent5f1ba08953dfa44aee9efe4d38a50ffb3d949dc2 (diff)
downloadguix-patches-4509ec72a4f7034e9a7087e802a84bbe04f4c12c.tar
guix-patches-4509ec72a4f7034e9a7087e802a84bbe04f4c12c.tar.gz
gnu: emacs: Fix indentation of scheme keyword lists.
* gnu/packages/patches/emacs-fix-scheme-indent-function.patch: New patch. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/emacs.scm (emacs)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/emacs-fix-scheme-indent-function.patch')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
new file mode 100644
index 0000000000..c5a426802c
--- /dev/null
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -0,0 +1,29 @@
+Fix 'scheme-indent-function' to indent s-expressions starting with a keyword
+properly, like this:
+
+(#:foo 1
+ #:bar 2)
+
+instead of like this:
+
+(#:foo 1
+ #:bar 2)
+
+The fix is made by Mark H Weaver <mhw@netris.org>:
+<http://www.netris.org/~mhw/scheme-indent-function.el>
+
+--- a/lisp/progmodes/scheme.el
++++ b/lisp/progmodes/scheme.el
+@@ -482,6 +482,12 @@
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
++ ((and (null method)
++ (> (length function) 1)
++ ;; The '#' in '#:' seems to get lost, not sure why
++ (string-match "\\`:" function))
++ (let ((lisp-body-indent 1))
++ (lisp-indent-defform state indent-point)))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))