summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/classpath-aarch64-support.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-03-26 12:19:14 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-03-26 12:21:33 +0300
commitbab9793f54f055e814428fe6e312b0f80b629333 (patch)
tree6bc75014e0697dd9038dd15a63adc5f306048789 /gnu/packages/patches/classpath-aarch64-support.patch
parent5dc8f5de0c97731d96435b1917c8a2e159fac441 (diff)
downloadguix-patches-bab9793f54f055e814428fe6e312b0f80b629333.tar
guix-patches-bab9793f54f055e814428fe6e312b0f80b629333.tar.gz
gnu: classpath: Add aarch64-linux support.
* gnu/packages/java.scm (classpath-bootstrap, classpath-0.99)[source]: Add patch. * gnu/packages/patches/classpath-aarch64-support.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/classpath-aarch64-support.patch')
-rw-r--r--gnu/packages/patches/classpath-aarch64-support.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/classpath-aarch64-support.patch b/gnu/packages/patches/classpath-aarch64-support.patch
new file mode 100644
index 0000000000..6fdac0c4fb
--- /dev/null
+++ b/gnu/packages/patches/classpath-aarch64-support.patch
@@ -0,0 +1,29 @@
+This is modeled after the ia64 support. Aarch64 can be either big endian
+or little endian, so we add the case for both.
+
+---
+ native/fdlibm/ieeefp.h | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/native/fdlibm/ieeefp.h b/native/fdlibm/ieeefp.h
+index 1a9740f..73455c0 100644
+--- a/native/fdlibm/ieeefp.h
++++ b/native/fdlibm/ieeefp.h
+@@ -27,6 +27,14 @@
+ #endif
+ #endif
+
++#ifdef __aarch64__
++#ifdef __BIG_ENDIAN__
++#define __IEEE_BIG_ENDIAN
++#else
++#define __IEEE_LITTLE_ENDIAN
++#endif
++#endif
++
+ #ifdef __hppa__
+ #define __IEEE_BIG_ENDIAN
+ #endif
+--
+2.16.3
+