summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/clamav-config-llvm-libs.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-10-28 22:42:59 -0500
committerEric Bavier <bavier@member.fsf.org>2018-11-17 00:20:44 -0600
commit0a41123f01d5d2466d6f533be3644ac8c9a2bdf9 (patch)
treef0fbbe9815ee6b4d4e1da46fe1f7cd3e68fae0e7 /gnu/packages/patches/clamav-config-llvm-libs.patch
parent7ed018e8a2f885246461ad65420bf39d741d343c (diff)
downloadguix-patches-0a41123f01d5d2466d6f533be3644ac8c9a2bdf9.tar
guix-patches-0a41123f01d5d2466d6f533be3644ac8c9a2bdf9.tar.gz
gnu: Add ClamAV.
* gnu/packages/antivirus.scm: New file. * gnu/packages/patches/clamav-system-tomsfastmath.patch, gnu/packages/patches/clamav-config-llvm-libs.patch: New files. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new module. (dist_patch_DATA): Add patches. Co-authored-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/patches/clamav-config-llvm-libs.patch')
-rw-r--r--gnu/packages/patches/clamav-config-llvm-libs.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/clamav-config-llvm-libs.patch b/gnu/packages/patches/clamav-config-llvm-libs.patch
new file mode 100644
index 0000000000..054264ee2e
--- /dev/null
+++ b/gnu/packages/patches/clamav-config-llvm-libs.patch
@@ -0,0 +1,14 @@
+Our llvm does not contain a single top-level library, so consult llvm-config
+for the libraries that need to be linked against.
+
+--- clamav-0.100.2/libclamav/c++/configure.ac 2018-09-19 14:29:07.000000000 -0500
++++ clamav-0.100.2/libclamav/c++/configure.ac 2018-10-06 21:45:09.377249158 -0500
+@@ -105,7 +105,7 @@
+
+ if test "x$llvm_linking" = "xdynamic"; then
+ AC_SUBST(LLVMCONFIG_LDFLAGS, [`$llvmconfig --ldflags`])
+- AC_SUBST(LLVMCONFIG_LIBS, [-lLLVM-$llvmver])
++ AC_SUBST(LLVMCONFIG_LIBS, [`$llvmconfig --libs $llvmcomp`])
+ AC_SUBST(LLVMCONFIG_LIBFILES, [])
+ else
+ if test $llvmver_test -ge 350; then