summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ceph-boost-compat.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-11-05 22:49:43 +0100
committerMarius Bakke <marius@gnu.org>2021-11-06 17:41:41 +0100
commit1525443e02f5462934d32904973692541b7057d7 (patch)
treea250ff22e86bbc3d70c6a6fb991cb069f56e7e84 /gnu/packages/patches/ceph-boost-compat.patch
parent075df3d3e2f86ad2548075969b34402a3c40ec42 (diff)
downloadguix-patches-1525443e02f5462934d32904973692541b7057d7.tar
guix-patches-1525443e02f5462934d32904973692541b7057d7.tar.gz
gnu: ceph: Update to 16.2.6.
* gnu/packages/storage.scm (ceph): Update to 16.2.6. [source](patches): Add two new patches. Remove one obsolete. [source](snippet): Unbundle fmt. [arguments]: Remove -DWITH_PYTHON3 from #:configure-flags. Add -DWITH_SYSTEMD. Adjust RUNPATH substitution, and the wrap-python-scripts phase, for upstream changes. Remove trailing #t's. [inputs]: Remove PYTHON-SIX and PYTHON-WRAPPER. Add FMT, ICU4C, PYTHON-PYYAML, PYTHON, and SQLITE. * gnu/packages/patches/ceph-fix-snappy-breaking-change.patch: Delete file. * gnu/packages/patches/ceph-boost-compat.patch, gnu/packages/patches/ceph-rocksdb-compat.patch: New files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/ceph-boost-compat.patch')
-rw-r--r--gnu/packages/patches/ceph-boost-compat.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-boost-compat.patch b/gnu/packages/patches/ceph-boost-compat.patch
new file mode 100644
index 0000000000..1aecfbbed5
--- /dev/null
+++ b/gnu/packages/patches/ceph-boost-compat.patch
@@ -0,0 +1,18 @@
+Add extra includes required for Boost 1.75 and later.
+
+Taken from upstram:
+
+ https://github.com/ceph/ceph/commit/ebf3a0398f18eab67d2ba25e6a10b41ff140f6a4
+
+diff --git a/src/rgw/rgw_string.h b/src/rgw/rgw_string.h
+index 257daa9c1fe6e..90e64f98a2587 100644
+--- a/src/rgw/rgw_string.h
++++ b/src/rgw/rgw_string.h
+@@ -8,5 +8,7 @@
+ #include <stdlib.h>
+ #include <limits.h>
+ #include <string_view>
++#include <string>
++#include <stdexcept>
+
+ #include <boost/container/small_vector.hpp>