summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bsd-games-stdio.h.patch
diff options
context:
space:
mode:
authorVitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>2020-04-24 20:18:31 +0700
committerGuix Patches Tester <>2020-04-24 15:09:16 +0100
commit55aceef934b8e8165e1653e9fbf80604fda72b65 (patch)
tree5ad3587ba26025a36662fe8ff572d0142cda00f4 /gnu/packages/patches/bsd-games-stdio.h.patch
parent4ac3461a80338c9596b938b25d6f517af43330f0 (diff)
downloadguix-patches-55aceef934b8e8165e1653e9fbf80604fda72b65.tar
guix-patches-55aceef934b8e8165e1653e9fbf80604fda72b65.tar.gz
gnu: Add bsd-games.
* gnu/packages/games.scm (bsd-games): a new variable. New patches, taken from Arch and Debian: * gnu/packages/patches/bsd-games-2.17-64bit.patch * gnu/packages/patches/bsd-games-bad-ntohl-cast.patch * gnu/packages/patches/bsd-games-fix-number-test.patch * gnu/packages/patches/bsd-games-gamescreen.h.patch * gnu/packages/patches/bsd-games-getline.patch * gnu/packages/patches/bsd-games-null-check.patch * gnu/packages/patches/bsd-games-number.c.patch * gnu/packages/patches/bsd-games-stdio.h.patch New patches: * gnu/packages/patches/bsd-games-add-configure-config.patch * gnu/packages/patches/bsd-games-add-word-list.patch * gnu/packages/patches/bsd-games-add-wrapper.patch * gnu/packages/patches/bsd-games-dont-install-empty-files.patch * gnu/packages/patches/bsd-games-use-anthology-style-naming.patch
Diffstat (limited to 'gnu/packages/patches/bsd-games-stdio.h.patch')
-rw-r--r--gnu/packages/patches/bsd-games-stdio.h.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/bsd-games-stdio.h.patch b/gnu/packages/patches/bsd-games-stdio.h.patch
new file mode 100644
index 0000000000..786fa54c4f
--- /dev/null
+++ b/gnu/packages/patches/bsd-games-stdio.h.patch
@@ -0,0 +1,14 @@
+diff -ru a/include/stdio.h b/include/stdio.h
+--- a/include/stdio.h 2000-08-04 10:24:39.000000000 +1000
++++ b/include/stdio.h 2005-06-18 14:26:35.000000000 +1000
+@@ -34,6 +34,10 @@
+ #include <bsd-games.h>
+ #include_next <stdio.h>
+
++__BEGIN_DECLS
++
+ #ifndef HAVE_fgetln
+ extern char *fgetln(FILE *stream, size_t *len);
+ #endif
++
++__END_DECLS