summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/bash-completion-directories.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 14:43:23 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 14:44:13 +0100
commit504be7db587d5ba2f5d777b45920f3f1229b7243 (patch)
treea585de2fc3fb6c7e49133e4d7150f7b64e2b5308 /gnu/packages/patches/bash-completion-directories.patch
parent39c6af47741f04e07693ccd4de8cc13456bafcfb (diff)
downloadguix-patches-504be7db587d5ba2f5d777b45920f3f1229b7243.tar
guix-patches-504be7db587d5ba2f5d777b45920f3f1229b7243.tar.gz
gnu: bash-completion: Update to 2.8.
* gnu/packages/bash.scm (bash-completion): Update to 2.8. * gnu/packages/patches/bash-completion-directories.patch: Update context.
Diffstat (limited to 'gnu/packages/patches/bash-completion-directories.patch')
-rw-r--r--gnu/packages/patches/bash-completion-directories.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/patches/bash-completion-directories.patch b/gnu/packages/patches/bash-completion-directories.patch
index 351a8e02fb..164096f16c 100644
--- a/gnu/packages/patches/bash-completion-directories.patch
+++ b/gnu/packages/patches/bash-completion-directories.patch
@@ -8,9 +8,9 @@ directory, but also in the user's profile and in the system profile.
This is what this patch does.
---- a/bash_completion 2016-08-03 10:23:02.356782287 +0200
-+++ b/bash_completion 2016-08-03 10:27:50.120140403 +0200
-@@ -1960,7 +1960,13 @@
+--- a/bash_completion
++++ b/bash_completion
+@@ -2016,7 +2016,13 @@ complete -F _minimal ''
__load_completion()
{
@@ -22,6 +22,6 @@ This is what this patch does.
+ "/run/current-system/profile/etc/bash_completion.d/$base"
+ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions )
+
- local OIFS=$IFS IFS=: dir cmd="$1" compfile
+ local OIFS=$IFS IFS=: dir cmd="${1##*/}" compfile
for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do
dirs+=( $dir/bash-completion/completions )