summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-checksums-cmake-prefix.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:41:08 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commit4c66a8deb5f51fd4f944fb62c43aa1e2a477711c (patch)
tree7be4542b6501a0d2cbc006b98f1b75c727fd0a72 /gnu/packages/patches/aws-checksums-cmake-prefix.patch
parent5f998a5cdbbb3034c3948b3e73cc90b656ef8431 (diff)
downloadguix-patches-4c66a8deb5f51fd4f944fb62c43aa1e2a477711c.tar
guix-patches-4c66a8deb5f51fd4f944fb62c43aa1e2a477711c.tar.gz
gnu: Add aws-checksums.
* gnu/packages/c.scm (aws-checksums): New variable. * gnu/packages/patches/aws-checksums-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-checksums-cmake-prefix.patch')
-rw-r--r--gnu/packages/patches/aws-checksums-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-checksums-cmake-prefix.patch b/gnu/packages/patches/aws-checksums-cmake-prefix.patch
new file mode 100644
index 0000000000..f6a5c9ad9c
--- /dev/null
+++ b/gnu/packages/patches/aws-checksums-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,6 +8,10 @@
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()