summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/aws-c-io-cmake-prefix.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-01-19 12:53:18 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-12 23:58:54 +0100
commit8ea7b6f91e42133181dc7d48df3f92bfa4bb67c3 (patch)
treeee97128bd6ebe4d7a6d4ddeab73c2ad2ea9c4d63 /gnu/packages/patches/aws-c-io-cmake-prefix.patch
parent1b518888638dce0c44192e8c0bbcb40752d162b4 (diff)
downloadguix-patches-8ea7b6f91e42133181dc7d48df3f92bfa4bb67c3.tar
guix-patches-8ea7b6f91e42133181dc7d48df3f92bfa4bb67c3.tar.gz
gnu: Add aws-c-io.
* gnu/packages/c.scm (aws-c-io): New variable. * gnu/packages/patches/aws-c-io-cmake-prefix.patch, gnu/packages/patches/aws-c-io-disable-networking-tests.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/aws-c-io-cmake-prefix.patch')
-rw-r--r--gnu/packages/patches/aws-c-io-cmake-prefix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/aws-c-io-cmake-prefix.patch b/gnu/packages/patches/aws-c-io-cmake-prefix.patch
new file mode 100644
index 0000000000..da3e4eb4a5
--- /dev/null
+++ b/gnu/packages/patches/aws-c-io-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()