summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/antiword-CVE-2014-8123.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-05-30 09:35:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-05-30 09:57:09 +0300
commit9116f1269089ecf88ed9465498f7f9482dd978c6 (patch)
tree40092433e7ebd4eb82cb5dc5e83970c4bcdf5975 /gnu/packages/patches/antiword-CVE-2014-8123.patch
parentd01f680c07294b4b8e981ac78da5b551951175bc (diff)
downloadguix-patches-9116f1269089ecf88ed9465498f7f9482dd978c6.tar
guix-patches-9116f1269089ecf88ed9465498f7f9482dd978c6.tar.gz
gnu: antiword: Fix CVE-2014-8123.
* gnu/packages/textutils.scm (antiword)[source]: Add patch. * gnu/packages/patches/antiword-CVE-2014-8123: New variable. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/antiword-CVE-2014-8123.patch')
-rw-r--r--gnu/packages/patches/antiword-CVE-2014-8123.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/antiword-CVE-2014-8123.patch b/gnu/packages/patches/antiword-CVE-2014-8123.patch
new file mode 100644
index 0000000000..d8d346a634
--- /dev/null
+++ b/gnu/packages/patches/antiword-CVE-2014-8123.patch
@@ -0,0 +1,21 @@
+Description: Add check for buffer overflow with malformed input files
+ This was later re-found and became CVE-2014-8123.
+Author: <eriks@debian.org>
+Bug-Debian: http://bugs.debian.org/407015
+Bug-Debian: https://bugs.debian.org/771768
+Forwarded: http://seclists.org/oss-sec/2014/q4/870
+Last-Update: 2016-01-11
+
+--- antiword-0.37~/wordole.c 2005-08-26 21:49:57.000000000 +0200
++++ antiword-0.37/wordole.c 2009-06-03 22:31:15.948014682 +0200
+@@ -259,6 +259,10 @@
+ }
+ tNameSize = (size_t)usGetWord(0x40, aucBytes);
+ tNameSize = (tNameSize + 1) / 2;
++ if ( tNameSize > sizeof(atPPSlist[iIndex].szName)) {
++ werr(0, "Name Size of PPS %d is too large", iIndex);
++ tNameSize = sizeof(atPPSlist[iIndex].szName);
++ }
+ vName2String(atPPSlist[iIndex].szName, aucBytes, tNameSize);
+ atPPSlist[iIndex].ucType = ucGetByte(0x42, aucBytes);
+ if (atPPSlist[iIndex].ucType == 5) {