summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-01 10:22:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-01 10:55:44 +0200
commit0109b89c5834b5374f248dc3681702180013f41f (patch)
treeeb2da91fcc31cd2131b34827331747507c34de37 /gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch
parentd5c60e0aff8c71d66e598e2c7787a9f7c875fd0c (diff)
downloadguix-patches-0109b89c5834b5374f248dc3681702180013f41f.tar
guix-patches-0109b89c5834b5374f248dc3681702180013f41f.tar.gz
gnu: allegro@5.0: Fix building with newer mesa.
* gnu/packages/game-development.scm (allegro@5.0)[source]: Add patch. (allegro)[patch]: Rename patch file. * gnu/packages/patches/allegro-fix-compiliation-mesa-18.2.5-and-later.patch: Rename to gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch')
-rw-r--r--gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch b/gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch
new file mode 100644
index 0000000000..fa273a5dfa
--- /dev/null
+++ b/gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch
@@ -0,0 +1,41 @@
+Fixes compilation with Mesa >= 18.2.5.
+
+Taken from upstream:
+
+https://github.com/liballeg/allegro5/commit/a40d30e21802ecf5c9382cf34af9b01bd3781e47
+
+diff --git a/include/allegro5/allegro_opengl.h b/include/allegro5/allegro_opengl.h
+index 0f86a6768..652dd024e 100644
+--- a/include/allegro5/allegro_opengl.h
++++ b/include/allegro5/allegro_opengl.h
+@@ -103,10 +103,14 @@
+
+ /* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
+ #define __glext_h_
++#define __gl_glext_h_
+ #define __glxext_h_
++#define __glx_glxext_h_
+ #include <GL/gl.h>
+ #undef __glext_h_
++#undef __gl_glext_h_
+ #undef __glxext_h_
++#undef __glx_glxext_h_
+
+ #endif /* ALLEGRO_MACOSX */
+
+diff --git a/include/allegro5/opengl/GLext/glx_ext_defs.h b/include/allegro5/opengl/GLext/glx_ext_defs.h
+index 49c502091..fba8aea5d 100644
+--- a/include/allegro5/opengl/GLext/glx_ext_defs.h
++++ b/include/allegro5/opengl/GLext/glx_ext_defs.h
+@@ -1,7 +1,9 @@
+ /* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
+ #define __glxext_h_
++#define __glx_glxext_h_
+ #include <GL/glx.h>
+ #undef __glxext_h_
++#undef __glx_glxext_h_
+
+ #ifndef GLX_VERSION_1_3
+ #define _ALLEGRO_GLX_VERSION_1_3
+--
+2.20.0