summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/agg-2.5-gcc8.patch
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-11-29 14:58:39 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-11-29 14:58:39 +0100
commitf22dfba53032c59fb260173143abf0e4e9a4f1e1 (patch)
tree1a40a2db3da9c51dcd5f1c273acddf029a7294ab /gnu/packages/patches/agg-2.5-gcc8.patch
parent3d54f2415672aed64661bed84a043a7f0cee13dd (diff)
downloadguix-patches-f22dfba53032c59fb260173143abf0e4e9a4f1e1.tar
guix-patches-f22dfba53032c59fb260173143abf0e4e9a4f1e1.tar.gz
gnu: agg: Fix build.
* gnu/packages/patches/agg-2.5-gcc8.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/graphics.scm (agg)[source]: Use it.
Diffstat (limited to 'gnu/packages/patches/agg-2.5-gcc8.patch')
-rw-r--r--gnu/packages/patches/agg-2.5-gcc8.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/agg-2.5-gcc8.patch b/gnu/packages/patches/agg-2.5-gcc8.patch
new file mode 100644
index 0000000000..dfcfc6cd4a
--- /dev/null
+++ b/gnu/packages/patches/agg-2.5-gcc8.patch
@@ -0,0 +1,14 @@
+Taken from: https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-libs/agg/files/agg-2.5-gcc8.patch.
+
+diff -uprN agg-2.5/include/agg_renderer_outline_aa.h agg-2.5-fixed/include/agg_renderer_outline_aa.h
+--- agg-2.5/include/agg_renderer_outline_aa.h 2018-08-25 02:02:52.507254241 +0800
++++ agg-2.5-fixed/include/agg_renderer_outline_aa.h 2018-08-25 02:04:15.291175316 +0800
+@@ -1375,7 +1375,7 @@ namespace agg
+ //---------------------------------------------------------------------
+ void profile(const line_profile_aa& prof) { m_profile = &prof; }
+ const line_profile_aa& profile() const { return *m_profile; }
+- line_profile_aa& profile() { return *m_profile; }
++ const line_profile_aa& profile() { return *m_profile; }
+
+ //---------------------------------------------------------------------
+ int subpixel_width() const { return m_profile->subpixel_width(); }