summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abseil-cpp-fix-gtest.patch
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-03-11 20:53:15 +0000
committerLudovic Courtès <ludo@gnu.org>2021-03-19 22:32:40 +0100
commit6457985e39d794c0f44d953d475aa19c41025d00 (patch)
tree91b7a61e434fdab56399c251adfbbe96e283276f /gnu/packages/patches/abseil-cpp-fix-gtest.patch
parentc4d616f7c665921e1329c75cd2d0cf05094b1306 (diff)
downloadguix-patches-6457985e39d794c0f44d953d475aa19c41025d00.tar
guix-patches-6457985e39d794c0f44d953d475aa19c41025d00.tar.gz
gnu: abseil-cpp: Patch sterror_test.
* gnu/packages/patches/abseil-cpp-fix-gtest.patch: Renamed file. * gnu/packages/patches/abseil-cpp-fix-strerror_test.patch: New file. * gnu/local.mk (dist_patch_DATA): Rename / add files. * gnu/packages/cpp.scm (abseil-cpp)[source]: Use files. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/abseil-cpp-fix-gtest.patch')
-rw-r--r--gnu/packages/patches/abseil-cpp-fix-gtest.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/abseil-cpp-fix-gtest.patch b/gnu/packages/patches/abseil-cpp-fix-gtest.patch
new file mode 100644
index 0000000000..38971448f3
--- /dev/null
+++ b/gnu/packages/patches/abseil-cpp-fix-gtest.patch
@@ -0,0 +1,16 @@
+The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
+in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
+a googletest release.
+
+--- a/absl/container/internal/unordered_map_modifiers_test.h
++++ b/absl/container/internal/unordered_map_modifiers_test.h
+@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
+ }
+ };
+
++#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
+ GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
++#endif
+
+ TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
+