summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/abiword-explictly-cast-bools.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-05 13:25:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-05 13:25:56 +0200
commit5c97ce1ea9378ee01688ede3837ab6a76964da9a (patch)
tree5cab99e112bd5541b41a94bd56a41b1742456650 /gnu/packages/patches/abiword-explictly-cast-bools.patch
parentad7f6e5f0d618bafc4430b77f6d85892a7762818 (diff)
downloadguix-patches-5c97ce1ea9378ee01688ede3837ab6a76964da9a.tar
guix-patches-5c97ce1ea9378ee01688ede3837ab6a76964da9a.tar.gz
gnu: abiword: Update to 3.0.2.
* gnu/packages/patches/abiword-explictly-cast-bools.patch: Update patch. * gnu/packages/patches/abiword-black-drawing-with-gtk322.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/abiword.scm (abiword): Update to 3.0.2. [source]: Remove outdated snippet; add new patch. [arguments]: Pass CXXFLAGS.
Diffstat (limited to 'gnu/packages/patches/abiword-explictly-cast-bools.patch')
-rw-r--r--gnu/packages/patches/abiword-explictly-cast-bools.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/abiword-explictly-cast-bools.patch b/gnu/packages/patches/abiword-explictly-cast-bools.patch
index 7927a180ba..97ae6653c2 100644
--- a/gnu/packages/patches/abiword-explictly-cast-bools.patch
+++ b/gnu/packages/patches/abiword-explictly-cast-bools.patch
@@ -2,18 +2,18 @@ As of JPEG-9, the type 'boolean' is an enumeration, but since glib defines
TRUE and FALSE as numeric constants and this is C++, they need to be explicitly
casted.
---- a/src/af/util/xp/ut_jpeg.cpp 2009-07-08 19:33:53.000000000 +0200
-+++ b/src/af/util/xp/ut_jpeg.cpp 2014-09-06 19:55:55.876997404 +0200
-@@ -102,7 +102,7 @@
+--- a/src/af/util/xp/ut_jpeg.cpp
++++ b/src/af/util/xp/ut_jpeg.cpp
+@@ -102,7 +102,7 @@ static boolean _jpegFillInputBuffer (j_decompress_ptr cinfo)
src->pub.next_input_byte = src->sourceBuf->getPointer (src->pos);
src->pub.bytes_in_buffer = src->sourceBuf->getLength ();
-
-- return TRUE;
+
+- return 1; // boolean is a libjpeg type that is an int.
+ return (boolean)TRUE;
}
/*
-@@ -161,7 +161,7 @@
+@@ -161,7 +161,7 @@ bool UT_JPEG_getDimensions(const UT_ByteBuf* pBB, UT_sint32& iImageWidth,
/* set the data source */
_JPEG_ByteBufSrc (&cinfo, pBB);
@@ -22,7 +22,7 @@ casted.
jpeg_start_decompress(&cinfo);
iImageWidth = cinfo.output_width;
iImageHeight = cinfo.output_height;
-@@ -189,7 +189,7 @@
+@@ -189,7 +189,7 @@ bool UT_JPEG_getRGBData(const UT_ByteBuf* pBB, UT_Byte* pDest, UT_sint32 iDestRo
/* set the data source */
_JPEG_ByteBufSrc (&cinfo, pBB);