summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-07-23 22:56:40 +0200
committerPierre Neidhardt <ambrevar@gmail.com>2018-08-14 12:00:18 +0200
commitc10aa27866e160b2b5c9bc4d46f2ceda93d049f4 (patch)
tree6145607a16ac5fef1c748e76b68c68f349e38df8 /gnu/packages/password-utils.scm
parent242519ce7025bf09c3ba541faac6060eda52921d (diff)
downloadguix-patches-c10aa27866e160b2b5c9bc4d46f2ceda93d049f4.tar
guix-patches-c10aa27866e160b2b5c9bc4d46f2ceda93d049f4.tar.gz
gnu: Add hashcat.
* gnu/packages/password-utils.scm (hashcat): New variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index a4d7c33aac..fd2663b950 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -61,6 +62,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages opencl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages python-web)
@@ -697,3 +699,33 @@ rotating passwords on various web services. It makes it easier to rotate your
passwords, one at a time or in bulk, when security events or routine upkeep of
your online accounts makes it necessary.")
(license license:expat)))
+
+(define-public hashcat
+ (package
+ (name "hashcat")
+ (version "4.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hashcat.net/files/hashcat-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "170i2y32ykgzb1qf1wz3klwn31c09bviz4x3bnrwia65adqrj8xx"))))
+ (native-inputs
+ `(("opencl-headers" ,opencl-headers)))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ;no tests
+ #:make-flags (list (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "https://hashcat.net/hashcat/")
+ (synopsis "Advanced password recovery utility")
+ (description "Hashcat is an password recovery utility, supporting five
+unique modes of attack for over 200 highly-optimized hashing algorithms.
+Hashcat currently supports CPUs, GPUs, and other hardware accelerators on
+Linux, Windows, and macOS, and has facilities to help enable distributed
+password cracking.")
+ (license license:expat)))