summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-07 15:52:39 -0500
committerLeo Famulari <leo@famulari.name>2021-03-25 19:19:42 -0400
commita801c7379a534a2896a03a1a6f8b47eb92691b00 (patch)
tree777908afa9d55f8922fe618fdb7fa29383219732 /gnu/packages/password-utils.scm
parent0d8cea4f247272a36c307276253f014f271f1b56 (diff)
downloadguix-patches-a801c7379a534a2896a03a1a6f8b47eb92691b00.tar
guix-patches-a801c7379a534a2896a03a1a6f8b47eb92691b00.tar.gz
gnu: Remove QT 4.
For more information, see: https://lists.gnu.org/archive/html/guix-devel/2016-02/msg00596.html https://bugs.gnu.org/45704 * gnu/packages/qt.scm (qt-4, python2-pyqt-4): Remove variables. * gnu/packages/engineering.scm (qucs, qucs-s): Remove variables. * gnu/packages/messaging.scm (pybitmessage): Remove variable. * gnu/packages/password-utils.scm (keepassx): Remove variable. * gnu/packages/pdf.scm (poppler-qt4): Remove variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 0d86a3d69e..d7942a0f8b 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -179,37 +179,6 @@ algorithms AES or Twofish.")
;; the combined work falls under the GPLv3.
(license license:gpl3)))
-(define-public keepassx
- (package
- (name "keepassx")
- (version "2.0.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.keepassx.org/releases/" version
- "/keepassx-" version ".tar.gz"))
- (sha256
- (base32
- "1ia7cqx9ias38mnffsl7da7g1f66bcbjsi23k49sln0c6spb9zr3"))))
- (build-system cmake-build-system)
- (inputs
- `(("libgcrypt" ,libgcrypt)
- ("libxi" ,libxi)
- ("libxtst" ,libxtst)
- ("qt" ,qt-4)))
- (native-inputs
- `(("zlib" ,zlib)))
- (home-page "https://www.keepassx.org")
- (synopsis "Password manager")
- (description "KeePassX is a password manager or safe which helps you to
-manage your passwords in a secure way. You can put all your passwords in one
-database, which is locked with one master key or a key-file which can be stored
-on an external storage device. The databases are encrypted using the
-algorithms AES or Twofish.")
- ;; Non functional parts use various licences.
- (license license:gpl3)
- (properties `((superseded . ,keepassxc)))))
-
(define-public pwsafe
(package
(name "pwsafe")