summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2017-06-25 14:38:40 +0200
committerArun Isaac <arunisaac@systemreboot.net>2017-06-26 02:13:10 +0530
commita1714ff5c7be5b39e1989fa8160b214c086c60d7 (patch)
tree1f2dd52cf5da627a0612a315722f821222692836 /gnu/packages/password-utils.scm
parenta1b46bdc069e6e3bbc5b171fafbc40213611ff1f (diff)
downloadguix-patches-a1714ff5c7be5b39e1989fa8160b214c086c60d7.tar
guix-patches-a1714ff5c7be5b39e1989fa8160b214c086c60d7.tar.gz
gnu: Add pass-git-helper.
* gnu/packages/password-utils.scm (pass-git-helper): New variable. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 9cfacdb427..08591d1086 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,7 @@
#:use-module (gnu packages aidc)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages gtk)
@@ -410,3 +412,37 @@ Password Scheme\"} by Niels Provos and David Mazieres.")
(define-public python2-bcrypt
(package-with-python2 python-bcrypt))
+
+(define-public pass-git-helper
+ (package
+ (name "pass-git-helper")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/languitar/pass-git-helper/archive/release-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0lz5ncy44pz7z1j2nnyildx8sq33zi3xvg5nkwg25n11nasqh2xn"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-pass-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((password-store (assoc-ref inputs "password-store"))
+ (pass (string-append password-store "/bin/pass")))
+ (substitute* "pass-git-helper"
+ (("'pass'") (string-append "'" pass "'")))
+ #t))))))
+ (inputs
+ `(("python-pyxdg" ,python-pyxdg)
+ ("password-store" ,password-store)))
+ (home-page "https://github.com/languitar/pass-git-helper")
+ (synopsis "Git credential helper interfacing with pass")
+ (description "pass-git-helper is a git credential helper which allows to
+use pass, the standard unix password manager, as the credential backend for
+your git repositories. This is achieved by explicitly defining mappings
+between hosts and entries in the password store.")
+ (license license:lgpl3+)))