summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorTim Gesthuizen <tim.gesthuizen@yahoo.de>2019-10-15 19:45:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-10-15 22:01:23 +0300
commit747aa6c46baeb02bb75e5c199dd005eb9dd52785 (patch)
tree1e82b420e930b7a1dee961fd4bca7a025a09fe37 /gnu/packages/password-utils.scm
parent40cad6b956ad250eaa1b3bd259d048e152ce2674 (diff)
downloadguix-patches-747aa6c46baeb02bb75e5c199dd005eb9dd52785.tar
guix-patches-747aa6c46baeb02bb75e5c199dd005eb9dd52785.tar.gz
gnu: pwsafe: Update to 3.5.0
* gnu/packages/password-utils.scm (pwsafe): Update to 3.5.0. [source]: Use git-file-name. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index ff13be24db..ba488dde27 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -21,7 +21,7 @@
;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Amirouche Boubekki <amirouche@hypermove.net>
-;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2018, 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
;;;
;;; This file is part of GNU Guix.
@@ -183,16 +183,17 @@ algorithms AES or Twofish.")
(define-public pwsafe
(package
(name "pwsafe")
- (version "3.48.0")
- (home-page "https://www.pwsafe.org/" )
+ (version "3.50.0")
+ (home-page "https://www.pwsafe.org/")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/pwsafe/pwsafe.git")
(commit version)))
- (sha256 (base32 "0hxv23yh76liggxbjn4m132z15sklra8ms341xgzl4n5vjx30ihi"))
- (file-name (string-append name "-" version "-checkout"))))
+ (sha256
+ (base32 "01kfssd2vr64yh4dqhch58x36n3aj3hpj5n560f41rsxym69c6qs"))
+ (file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs `(("gettext" ,gettext-minimal)
("perl" ,perl)