summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorKonrad Hinsen <konrad.hinsen@fastmail.net>2018-02-28 15:21:24 +0100
committerLudovic Courtès <ludo@gnu.org>2018-02-28 22:47:48 +0100
commit649eb8b5674a92638c4cbb2562cfc45935c0f06e (patch)
treee2f890da7e1c161bab91e0e3c572ff498498e604 /gnu/packages/password-utils.scm
parent3c14e7e6bbc2f86f927816042df1a9f1c057e09c (diff)
downloadguix-patches-649eb8b5674a92638c4cbb2562cfc45935c0f06e.tar
guix-patches-649eb8b5674a92638c4cbb2562cfc45935c0f06e.tar.gz
gnu: Add sala.
* gnu/packages/password-utils.scm (sala): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 955302dcb7..96a51f0dd4 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -612,3 +613,31 @@ password hash types most commonly found on various Unix systems, supported out
of the box are Windows LM hashes, plus lots of other hashes and ciphers. This
is the community-enhanced, \"jumbo\" version of John the Ripper.")
(license license:gpl2+))))
+
+(define-public sala
+ (package
+ (name "sala")
+ (version "1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sala" version))
+ (sha256
+ (base32
+ "13qgmc3i2a0cqp8jqrfl93lnphfagb32pgfikc1gza2a14asxzi8"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Sala is supposed to work with Python 3.2 or higher,
+ ;; but it doesn't work with Python 3.6. Better stick
+ ;; to Python 2, which works fine.
+ `(#:python ,python-2))
+ (propagated-inputs
+ `(("gnupg" ,gnupg)
+ ("pwgen" ,pwgen)))
+ (home-page "http://www.digip.org/sala/")
+ (synopsis "Encrypted plaintext password store")
+ (description
+ "Store passwords and other bits of sensitive plain-text information
+to encrypted files on a directory hierarchy. The information is protected
+by GnuPG's symmetrical encryption.")
+ (license license:expat)))