summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-09-11 21:36:51 +0300
committerEfraim Flashner <efraim@flashner.co.il>2016-09-18 23:19:46 +0300
commit153e58c568631f69289c172746739f7bfc92e51e (patch)
treeda3c957aea65415f1c79f83f713ce793cc20c991 /gnu/packages/password-utils.scm
parent0aea283a65a7b0095c00abd5808523f4e02427d2 (diff)
downloadguix-patches-153e58c568631f69289c172746739f7bfc92e51e.tar
guix-patches-153e58c568631f69289c172746739f7bfc92e51e.tar.gz
gnu: Add python-bcrypt.
* gnu/packages/password-utils.scm (python-bcrypt): New variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 7288da6613..d2410c6106 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -334,3 +334,38 @@ through the pass command.")
(description "Argon2 provides a key derivation function that was declared
winner of the 2015 Password Hashing Competition.")
(license license:cc0)))
+
+(define-public python-bcrypt
+ (package
+ (name "python-bcrypt")
+ (version "3.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bcrypt" version))
+ (sha256
+ (base32
+ "1giy0dvd8gvq6flxh44np1v2nqwsji5qsnrz038mgwzgp7c20j75"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pycparser" ,python-pycparser)
+ ("python-pytest" ,python-pytest)))
+ (inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-six" ,python-six)))
+ (home-page "https://github.com/pyca/bcrypt/")
+ (synopsis
+ "Modern password hashing library")
+ (description
+ "Bcrypt is a Python module which provides a password hashing method based
+on the Blowfish password hashing algorithm, as described in
+@url{http://static.usenix.org/events/usenix99/provos.html,\"A Future-Adaptable
+Password Scheme\"} by Niels Provos and David Mazieres.")
+ (license license:asl2.0)))
+
+(define-public python2-bcrypt
+ (let ((bcrypt (package-with-python2 python-bcrypt)))
+ (package (inherit bcrypt)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs bcrypt))))))